Dim3PointAngular Object (ActiveX)

A dimension measuring the angular distance between three points.

Supported Platforms: Windows only

Class Information

Class Name

AcadDim3PointAngular

Object Inheritance
Object
   AcadObject
      AcadEntity
         AcadDimension
            AcadDim3PointAngular
Create Using

VBA

ModelSpace.AddDim3PointAngular
PaperSpace.AddDim3PointAngular
Block.AddDim3PointAngular
Access Via

VBA

ModelSpace.Item
PaperSpace.Item
Block.Item
SelectionSet.Item
Group.Item

Members

These members are part of this object:

Methods

Properties

Events

ArrayPolar

ArrayRectangular

Copy

Delete

GetBoundingBox

GetExtensionDictionary

GetXData

Highlight

IntersectWith

Mirror

Mirror3D

Move

Rotate

Rotate3D

ScaleEntity

SetXData

TransformBy

Update

AngleFormat

AngleVertex

Application

Arrowhead1Block

Arrowhead1Type

Arrowhead2Block

Arrowhead2Type

ArrowheadSize

DecimalSeparator

DimConstrDesc

DimConstrExpression

DimConstrForm

DimConstrName

DimConstrReference

DimConstrValue

DimensionLineColor

DimensionLinetype

DimensionLineWeight

DimLine1Suppress

DimLine2Suppress

DimLineInside

DimTxtDirection

Document

EntityTransparency

ExtensionLineColor

ExtensionLineExtend

ExtensionLineOffset

ExtensionLineWeight

ExtLine1EndPoint

ExtLine1Linetype

ExtLine1Suppress

ExtLine2EndPoint

ExtLine2Linetype

ExtLine2Suppress

ExtLineFixedLen

ExtLineFixedLenSuppress

Fit

ForceLineInside

Handle

HasExtensionDictionary

HorizontalTextPosition

Hyperlinks

Layer

Linetype

LinetypeScale

Lineweight

Material

Measurement

Normal

ObjectID

ObjectName

OwnerID

PlotStyleName

Rotation

ScaleFactor

StyleName

SuppressLeadingZeros

SuppressTrailingZeros

TextColor

TextFill

TextFillColor

TextGap

TextHeight

TextInside

TextInsideAlign

TextMovement

TextOutsideAlign

TextOverride

TextPosition

TextPrecision

TextPrefix

TextRotation

TextStyle

TextSuffix

ToleranceDisplay

ToleranceHeightScale

ToleranceJustification

ToleranceLowerLimit

TolerancePrecision

ToleranceSuppressLeadingZeros

ToleranceSuppressTrailingZeros

ToleranceUpperLimit

TrueColor

VerticalTextPosition

Visible

Modified

Remarks

When creating a three point angular dimension, AutoCAD draws the dimension line arc between the extension lines. The extension lines are drawn from the angle endpoints to the intersection of the dimension line arc.



A 3 point angular dimension

AutoCAD uses the location of the dimension line arc to choose between the minor and major angles specified by the angle vertex and extension lines.

To create a three point angular dimension, use the AddDim3PointAngular method.