TextRotation Property (ActiveX)

Specifies the rotation angle of the dimension text.

Supported platforms: Windows only

Signature

VBA:

object.TextRotation
object

Type: Dim3PointAngular, DimAligned, DimAngular, DimArcLength, DimDiametric, Dimension, DimOrdinate, DimRadial, DimRadialLarge, DimRotated, MLeader

The objects this property applies to.

Property Value

Read-only: No

Type: Double

The angle in radians of the dimension text. The valid range is 0 to 6.28.

Remarks

By default, this value is equal to either 0 degrees, or to the Rotation property, as specified by the dimension style.



Text with 0 degree angle

Text with angle equal to the dimension rotation

Examples

VBA:

Sub Example_TextRotation()
    ' This example creates an aligned dimension and then changes the
    ' TextRotation property for that dimension.

    Dim dimObj As AcadDimAligned
    Dim point1(0 To 2) As Double
    Dim point2(0 To 2) As Double
    Dim location(0 To 2) As Double
    
    ' Define the dimension
    point1(0) = 5#: point1(1) = 3#: point1(2) = 0#
    point2(0) = 10#: point2(1) = 3#: point2(2) = 0#
    location(0) = 7.5: location(1) = 5#: location(2) = 0#
    
    ' Create an aligned dimension object in model space
    Set dimObj = ThisDrawing.ModelSpace.AddDimAligned(point1, point2, location)
    ZoomAll
    MsgBox "The current text rotation angle for the dimension is " & dimObj.TextRotation & " radians.", vbInformation, "TextRotation Example"
    
    ' Change the text rotation angle to 45 degrees (.707 radians)
    dimObj.TextRotation = 0.707
    dimObj.Update
        
    MsgBox "The new text rotation angle for the dimension is " & dimObj.TextRotation & " radians.", vbInformation, "TextRotation Example"
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_TextRotation()
    ;; This example creates an aligned dimension and then changes the
    ;; TextRotation property for that dimension.
    (setq acadObj (vlax-get-acad-object))
    (setq doc (vla-get-ActiveDocument acadObj))
    
    ;; Define the dimension
    (setq point1 (vlax-3d-point 5 3 0)
          point2 (vlax-3d-point 10 3 0)
          location (vlax-3d-point 7.5 5 0))
    
    ;; Create an aligned dimension object in model space
    (setq modelSpace (vla-get-ModelSpace doc))
    (setq dimObj (vla-AddDimAligned modelSpace point1 point2 location))
    (vla-ZoomAll acadObj)
    (alert (strcat "The current text rotation angle for the dimension is " (rtos (vla-get-TextRotation dimObj) 2) " radians."))
    
    ;; Change the text rotation angle to 45 degrees (.707 radians)
    (vla-put-TextRotation dimObj 0.707)
    (vla-Update dimObj)
        
    (alert (strcat "The new text rotation angle for the dimension is " (rtos (vla-get-TextRotation dimObj) 2) " radians."))
)