3DSolid Object (ActiveX)

A solid object with free-form surface support.

Supported Platforms: Windows only

Class Information

Class Name

Acad3DSolid

Object Inheritance
Object
   AcadObject
      AcadEntity
         Acad3DSolid
Create Using

VBA

ModelSpace, PaperSpace, and Block objects use:
AddBox, AddCone, AddCylinder, AddEllipticalCone, AddEllipticalCylinder, 
AddExtrudedSolid, AddExtrudedSolidAlongPath, AddRevolvedSolid, 
AddSphere, AddTorus, or AddWedge 
Access Via

VBA

ModelSpace.Item
PaperSpace.Item
Block.Item
SelectionSet.Item
Group.Item

Members

These members are part of this object:

Remarks

You can make 3D objects by creating basic 3D shapes: boxes, cones, cylinders, spheres, wedges, and toriis (donuts). You can then combine these shapes to create more complex solids by joining or subtracting them or finding their intersecting (overlapping) volume. You can also create solids by sweeping a 2D object along a path or revolving it about an axis.

To create a 3DSolid, use one of the following methods: AddBox , AddCone , AddCylinder , AddEllipticalCone , AddEllipticalCylinder , AddExtrudedSolid , AddExtrudedSolidAlongPath , AddRevolvedSolid , AddSphere , AddTorus , AddWedge .