ToleranceDisplay Property (ActiveX)

Specifies if tolerances are displayed with the dimension text.

Supported platforms: Windows only

Signature

VBA:

object.ToleranceDisplay
object

Type: Dim3PointAngular, DimAligned, DimAngular, DimArcLength, DimDiametric, Dimension, DimOrdinate, DimRadial, DimRadialLarge, DimRotated

The object this property applies to.

Property Value

Read-only: No

Type: acDimToleranceMethod enum

Remarks

The initial value for this property is acTolNone.

Note: This property overrides the value of the DIMTOL system variable for the given dimension.

Examples

VBA:

Sub Example_ToleranceDisplay()
    ' This example creates an aligned dimension in model space and
    ' turns on the tolerance display for the new dimension

    Dim dimObj As AcadDimAligned
    Dim newText As AcadTextStyle
    Dim point1(0 To 2) As Double, point2(0 To 2) As Double
    Dim location(0 To 2) As Double
    Dim CurrentDisplay As String
    
    ' Define the dimension
    point1(0) = 5: point1(1) = 5: point1(2) = 0
    point2(0) = 5.5: point2(1) = 5: point2(2) = 0
    location(0) = 5: location(1) = 7: location(2) = 0
    
    ' Create an aligned dimension object in model space
    Set dimObj = ThisDrawing.ModelSpace.AddDimAligned(point1, point2, location)
    
    ThisDrawing.Application.ZoomAll
    
    ' Read and display the current tolerance display for this dimension
    CurrentDisplay = IIf(dimObj.ToleranceDisplay = acTolNone, "Hidden", "Visible")
    MsgBox "The tolerance display is currently: " & CurrentDisplay
    
    ' Toggle the tolerance display for this dimension
    If dimObj.ToleranceDisplay = acTolNone Then
        dimObj.ToleranceDisplay = acTolSymmetrical
        CurrentDisplay = "Symmetrical"
    Else
        dimObj.ToleranceDisplay = acTolNone
        CurrentDisplay = "None"
    End If
    
    ThisDrawing.Regen acAllViewports
    
    ' Display the current tolerance display for this dimension
    MsgBox "The tolerance display is now set to: " & CurrentDisplay

End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_ToleranceDisplay()
    ;; This example creates an aligned dimension in model space and
    ;; turns on the tolerance display for the new dimension
    (setq acadObj (vlax-get-acad-object))
    (setq doc (vla-get-ActiveDocument acadObj))
    
    ;; Define the dimension
    (setq point1 (vlax-3d-point 5 5 0)
          point2 (vlax-3d-point 5.5 5 0)
          location (vlax-3d-point 5 7 0))
    
    ;; Create an aligned dimension object in model space
    (setq modelSpace (vla-get-ModelSpace doc))
    (setq dimObj (vla-AddDimAligned modelSpace point1 point2 location))
    
    (vla-ZoomAll acadObj)
    
    ;; Read and display the current tolerance display for this dimension
    (setq currentDisplay (if (= (vla-get-ToleranceDisplay dimObj) acTolNone) "Hidden" "Visible"))
    (alert (strcat "The tolerance display is currently: " currentDisplay))
    
    ;; Toggle the tolerance display for this dimension
    (if (= (vla-get-ToleranceDisplay dimObj) acTolNone)
        (progn
            (vla-put-ToleranceDisplay dimObj acTolSymmetrical)
            (setq currentDisplay "Symmetrical")
        )
        (progn
            (vla-put-ToleranceDisplay dimObj acTolNone)
            (setq currentDisplay "None")
        )
    )
    
    (vla-Regen doc acAllViewports)
    
    ;; Display the current tolerance display for this dimension
    (alert (strcat "The tolerance display is now set to: " currentDisplay))
)