Specifies the text style for the dimension or tolerance text.
Supported platforms: Windows only
VBA:
object.TextStyle
Type: Dim3PointAngular, DimAligned, DimAngular, DimArcLength, DimDiametric, Dimension, DimOrdinate, DimRadial, DimRadialLarge, DimRotated, MLeaderStyle, Tolerance
The objects this property applies to.
Read-only: No
Type: String
The style for the dimension value.
The initial value for this property is STANDARD.
VBA:
Sub Example_TextStyle() ' This example creates an aligned dimension in model space and ' creates a new system text style. The new text style is then assigned to ' the new dimension Dim dimObj As AcadDimAligned Dim newText As AcadTextStyle Dim point1(0 To 2) As Double, point2(0 To 2) As Double Dim location(0 To 2) As Double ' Define the dimension point1(0) = 5: point1(1) = 5: point1(2) = 0 point2(0) = 5.5: point2(1) = 5: point2(2) = 0 location(0) = 5: location(1) = 7: location(2) = 0 ' Create an aligned dimension object in model space Set dimObj = ThisDrawing.ModelSpace.AddDimAligned(point1, point2, location) ' Create new text style Set newText = ThisDrawing.TextStyles.Add("MYSTYLE") newText.height = 0.5 ' Just set the height of the new style so we can differentiate ThisDrawing.Application.ZoomAll ' Read and display the current text style for this dimension MsgBox "The text style is currently set to: " & dimObj.textStyle ' Change the text style to use the new style we created dimObj.textStyle = "MYSTYLE" ThisDrawing.Regen acAllViewports ' Read and display the current text style for this dimension MsgBox "The text style is now set to: " & dimObj.textStyle End Sub
Visual LISP:
(vl-load-com) (defun c:Example_TextStyle() ;; This example creates an aligned dimension in model space and ;; creates a new system text style. The new text style is then assigned to ;; the new dimension (setq acadObj (vlax-get-acad-object)) (setq doc (vla-get-ActiveDocument acadObj)) ;; Define the dimension (setq point1 (vlax-3d-point 5 5 0) point2 (vlax-3d-point 5.5 5 0) location (vlax-3d-point 5 7 0)) ;; Create an aligned dimension object in model space (setq modelSpace (vla-get-ModelSpace doc)) (setq dimObj (vla-AddDimAligned modelSpace point1 point2 location)) ;; Create new text style (setq newText (vla-Add (vla-get-TextStyles doc) "MYSTYLE")) (vla-put-Height newText 0.5) ;; Just set the height of the new style so we can differentiate (vla-ZoomAll acadObj) (vla-Regen doc acAllViewports) ;; Read and display the current text style for this dimension (alert (strcat "The text style is currently set to: " (vla-get-TextStyle dimObj))) ;; Change the text style to use the new style we created (vla-put-TextStyle dimObj "MYSTYLE") (vla-Regen doc acAllViewports) ;; Read and display the current text style for this dimension (alert (strcat "The text style is now set to: " (vla-get-TextStyle dimObj))) )