ArrowheadSize Property (ActiveX)

Specifies the size of dimension line arrowheads, leader and mleader line arrowheads, and hook lines.

Supported platforms: Windows only

Signature

VBA:

object.ArrowheadSize
object

Type: Dim3PointAngular, DimAligned, DimAngular, DimArcLength, DimDiametric, DimOrdinate, DimRadial, DimRadialLarge, DimRotated, Leader, MLeader, MLeaderLeader

The objects this property applies to.

Property Value

Read-only: No

Type: Double

The size of the arrowhead must be specified as a positive real >= 0.0.

Remarks

The initial value for this property is 0.1800.

Multiples of the arrowhead size determine if dimension lines and text should fit between the extension lines. This property is also used to scale arrowhead blocks if set by DIMBLK. This property has no effect when DIMTSZ is other than zero.

Note: This property overrides the value of the DIMASZ system variable for the given dimension.

Examples

VBA:

Sub Example_ArrowHeadSize()
    ' This example creates a Dim3PointAngular object in model space
    ' and then alters the visible appearance (size) of its arrowheads
    ' using the ArrowHeadSize property
    
    Dim DimPointAngularObj As AcadDim3PointAngular
    Dim AngleVertex(0 To 2) As Double
    Dim FirstPoint(0 To 2) As Double, SecondPoint(0 To 2) As Double
    Dim TextPoint(0 To 2) As Double
    
    ' Define the new Dim3PointAngular object
    AngleVertex(0) = 0: AngleVertex(1) = 0: AngleVertex(2) = 0
    FirstPoint(0) = 2: FirstPoint(1) = 2: FirstPoint(2) = 0
    SecondPoint(0) = 1: SecondPoint(1) = 4: SecondPoint(2) = 0
    TextPoint(0) = 6: TextPoint(1) = 6: TextPoint(2) = 0

    ' Create the new Dim3PointAngular object in model space
    Set DimPointAngularObj = ThisDrawing.ModelSpace.AddDim3PointAngular(AngleVertex, FirstPoint, SecondPoint, TextPoint)
    ThisDrawing.Application.ZoomAll

    ' Read and display current arrowhead size
    MsgBox "The arrowhead size for this object is currently set to: " & DimPointAngularObj.ArrowheadSize

    ' Alter the arrowhead size property for this object
    DimPointAngularObj.ArrowheadSize = 0.5
    ThisDrawing.Regen acAllViewports
    
    ' Read and display new arrowhead size setting
    MsgBox "The arrowhead size for this object is now set to: " & DimPointAngularObj.ArrowheadSize
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_ArrowHeadSize()
    ;; This example creates a Dim3PointAngular object in model space
    ;; and then alters the visible appearance (size) of its arrowheads
    ;; using the ArrowHeadSize property
    (setq acadObj (vlax-get-acad-object))
    (setq doc (vla-get-ActiveDocument acadObj))

    ;; Define the new Dim3PointAngular object
    (setq AngleVertex (vlax-3d-point 0 0 0)
          FirstPoint (vlax-3d-point 2 2 0)
          SecondPoint (vlax-3d-point 1 4 0)
          TextPoint (vlax-3d-point 6 6 0))

    ;; Create the new Dim3PointAngular object in model space
    (setq modelSpace (vla-get-ModelSpace doc))  
    (setq DimPointAngularObj (vla-AddDim3PointAngular modelSpace AngleVertex FirstPoint SecondPoint TextPoint))
    (vla-ZoomAll acadObj)

    ;; Read and display current arrowhead size
    (alert (strcat "The arrowhead size for this object is currently set to: " (rtos (vla-get-ArrowheadSize DimPointAngularObj) 2)))

    ;; Alter the arrowhead size property for this object
    (vla-put-ArrowheadSize DimPointAngularObj 0.5)
    (vla-Regen doc acAllViewports)
    
    ;; Read and display new arrowhead size setting
    (alert (strcat "The arrowhead size for this object is now set to: " (rtos (vla-get-ArrowheadSize DimPointAngularObj) 2)))
)