Measurement Property (ActiveX)

Gets the measurement for the dimension.

Supported platforms: Windows only

Signature

VBA:

object.Measurement
object

Type: Dim3PointAngular, DimAligned, DimAngular, DimArcLength, DimDiametric, DimOrdinate, DimRadial, DimRadialLarge, DimRotated

The objects this property applies to.

Property Value

Read-only: Yes

Type: Double

For linear dimensions this is a length, for angular dimensions it is an angle.

Remarks

For non-angular dimensions, this property overrides the value for the DIMLUNIT system variable.

For angular dimension, this property overrides the value for the DIMAUNIT system variable.

Examples

VBA:

Sub Example_Measurement()
    ' This example creates an aligned dimension in model space
    ' and returns the measurement of the dimension; in the case
    ' of a linear dimension, this measurement will be its length
    
    Dim dimObj As AcadDimAligned
    Dim point1(0 To 2) As Double, point2(0 To 2) As Double
    Dim location(0 To 2) As Double
    Dim CurrentValue As String
    
    ' Define the dimension
    point1(0) = 5: point1(1) = 5: point1(2) = 0
    point2(0) = 9: point2(1) = 5: point2(2) = 0
    location(0) = 5: location(1) = 7: location(2) = 0
    
    ' Create an aligned dimension object in model space
    Set dimObj = ThisDrawing.ModelSpace.AddDimAligned(point1, point2, location)
    ThisDrawing.Application.ZoomAll

    ' Read and display current measurement
    MsgBox "The current measurement of the new dimension is: " & dimObj.Measurement
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_Measurement()
    ;; This example creates an aligned dimension in model space
    ;; and returns the measurement of the dimension; in the case
    ;; of a linear dimension, this measurement will be its length
    (setq acadObj (vlax-get-acad-object))
    (setq doc (vla-get-ActiveDocument acadObj))
    
    ;; Define the dimension
    (setq point1 (vlax-3d-point 5 5 0)
          point2 (vlax-3d-point 9 5 0)
          location (vlax-3d-point 5 7 0))
    
    ;; Create an aligned dimension object in model space
    (setq modelSpace (vla-get-ModelSpace doc))
    (setq dimObj (vla-AddDimAligned modelSpace point1 point2 location))
    (vla-ZoomAll acadObj)

    ;; Read and display current measurement
    (alert (strcat "The current measurement of the new dimension is: " (rtos (vla-get-Measurement dimObj) 2)))
)