DimensionLineColor Property (ActiveX)

Specifies the color of the dimension line for a dimension, leader, or tolerance object.

Supported platforms: Windows only

Signature

VBA:

object.DimensionLineColor
object

Type: Dim3PointAngular, DimAligned, DimAngular, DimArcLength, DimDiametric, DimRadial, DimRadialLarge, DimRotated, Leader, Tolerance

The objects this property applies to.

Property Value

Read-only: No

Type: acColor enum

Use a color index number from 0 to 256, or one of the constants listed here:

Remarks

Colors can be set and read as numeric index values ranging from 0 to 256. Constants have been provided for the standard seven colors, as well as the BYBLOCK and BYLAYER designations.

If you use acByBlock, AutoCAD draws new objects in the default color (white or black, depending on your configuration) until they are grouped into the block. When the block is inserted in the drawing, the objects in the block inherit the current setting of the color property.

If you use acByLayer, new objects assume the color of the layer upon which they are drawn.

When you assign color to a dimension object, the color applies to the dimension lines, arrowheads, and dimension leader lines.

Note: This property overrides the value of the DIMCLRD system variable for the given dimension, leader, or tolerance object.

Examples

VBA:

Sub Example_DimensionLineColor()
    ' This example creates a Dim3PointAngular object in model space
    ' and changes the dimension line color to red using the DimensionLineColor property
    
    Dim DimPointAngularObj As AcadDim3PointAngular
    Dim AngleVertex(0 To 2) As Double
    Dim FirstPoint(0 To 2) As Double, SecondPoint(0 To 2) As Double
    Dim TextPoint(0 To 2) As Double
    
    ' Define the new Dim3PointAngular object
    AngleVertex(0) = 0: AngleVertex(1) = 0: AngleVertex(2) = 0
    FirstPoint(0) = 2: FirstPoint(1) = 2: FirstPoint(2) = 0
    SecondPoint(0) = 1: SecondPoint(1) = 4: SecondPoint(2) = 0
    TextPoint(0) = 6: TextPoint(1) = 6: TextPoint(2) = 0

    ' Create the new Dim3PointAngular object in model space
    Set DimPointAngularObj = ThisDrawing.ModelSpace.AddDim3PointAngular(AngleVertex, FirstPoint, SecondPoint, TextPoint)
    ThisDrawing.Application.ZoomAll

    ' Read and display current dimension line color
    MsgBox "The dimension line color for this object is currently set to: " & DimPointAngularObj.DimensionLineColor

    ' Change the dimension line color
    DimPointAngularObj.DimensionLineColor = acRed
    ThisDrawing.Regen acAllViewports
    
    ' Read and display current dimension line color
    MsgBox "The dimension line color for this object is now set to: " & DimPointAngularObj.DimensionLineColor & " (Red)"
    
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_DimensionLineColor()
    ;; This example creates a Dim3PointAngular object in model space
    ;; and changes the dimension line color to red using the DimensionLineColor property
    (setq acadObj (vlax-get-acad-object))
    (setq doc (vla-get-ActiveDocument acadObj))

    ;; Define the new Dim3PointAngular object
    (setq AngleVertex (vlax-3d-point 0 0 0)
          FirstPoint (vlax-3d-point 2 2 0)
          SecondPoint (vlax-3d-point 1 4 0)
          TextPoint (vlax-3d-point 6 6 0))

    ;; Create the new Dim3PointAngular object in model space
    (setq modelSpace (vla-get-ModelSpace doc))  
    (setq DimPointAngularObj (vla-AddDim3PointAngular modelSpace AngleVertex FirstPoint SecondPoint TextPoint))
    (vla-ZoomAll acadObj)

    ;; Read and display current dimension line color
    (alert (strcat "The dimension line color for this object is currently set to: " (itoa (vla-get-DimensionLineColor DimPointAngularObj))))

    ;; Change the dimension line color
    (vla-put-DimensionLineColor DimPointAngularObj acRed)
    (vla-Regen doc acAllViewports)
    
    ;; Read and display current dimension line color
    (alert (strcat "The dimension line color for this object is now set to: " (itoa (vla-get-DimensionLineColor DimPointAngularObj)) " (Red)"))
)