DimensionLineWeight Property (ActiveX)

Specifies the lineweight for the dimension lines.

Supported platforms: Windows only

Signature

VBA:

object.DimensionLineWeight
object

Type: Dim3PointAngular, DimAligned, DimAngular, DimArcLength, DimDiametric, DimRadial, DimRadialLarge, DimRotated, Leader

The objects this property applies to.

Property Value

Read-only: No

Type: acLineWeight enum

Remarks

The initial value for this property is acLnWtByBlock.

Lineweight settings are only visible when the LineweightDisplay property is set to True.

Examples

VBA:

Sub Example_DimensionLineWeight()
    ' This example creates a Dim3PointAngular object in model space
    ' and changes the dimension lineweight to a thicker value
    ' using the DimensionLineWeight property
    
    Dim DimPointAngularObj As AcadDim3PointAngular
    Dim AngleVertex(0 To 2) As Double
    Dim FirstPoint(0 To 2) As Double, SecondPoint(0 To 2) As Double
    Dim TextPoint(0 To 2) As Double
    Dim oldLWSetting As Boolean
    Dim CurrentSetting As String
        
    ' Turn on lineweight display so the changes can be seen
    oldLWSetting = ThisDrawing.preferences.LineWeightDisplay
    ThisDrawing.preferences.LineWeightDisplay = True
    
    ' Define the new Dim3PointAngular object
    AngleVertex(0) = 0: AngleVertex(1) = 0: AngleVertex(2) = 0
    FirstPoint(0) = 2: FirstPoint(1) = 2: FirstPoint(2) = 0
    SecondPoint(0) = 1: SecondPoint(1) = 4: SecondPoint(2) = 0
    TextPoint(0) = 6: TextPoint(1) = 6: TextPoint(2) = 0

    ' Create the new Dim3PointAngular object in model space
    Set DimPointAngularObj = ThisDrawing.ModelSpace.AddDim3PointAngular(AngleVertex, FirstPoint, SecondPoint, TextPoint)
    ThisDrawing.Application.ZoomAll

    ' Read and display current dimension lineweight
    CurrentSetting = DimPointAngularObj.DimensionLineWeight
    Select Case CurrentSetting
        Case acLnWtByLayer: CurrentSetting = "ByLayer"
        Case acLnWtByBlock: CurrentSetting = "ByBlock"
        Case acLnWtByLwDefault: CurrentSetting = "ByDefault"
        Case Else
    End Select

    MsgBox "The dimension lineweight setting for this object is currently set to: " & CurrentSetting

    ' Change the dimension lineweight
    DimPointAngularObj.DimensionLineWeight = acLnWt100
    ThisDrawing.Regen acAllViewports
    
    ' Read and display current dimension lineweight
    MsgBox "The dimension lineweight setting for this object is now set to: " & DimPointAngularObj.DimensionLineWeight
    
    ' Return previous lineweight setting
    ThisDrawing.preferences.LineWeightDisplay = oldLWSetting

End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_DimensionLineWeight()
    ;; This example creates a Dim3PointAngular object in model space
    ;; and changes the dimension lineweight to a thicker value
    ;; using the DimensionLineWeight property
    (setq acadObj (vlax-get-acad-object))
    (setq doc (vla-get-ActiveDocument acadObj))
    (setq preferences (vla-get-Preferences doc))
  
    ;; Turn on lineweight display so the changes can be seen
    (setq oldLWSetting (vla-get-LineWeightDisplay preferences))
    (vla-put-LineWeightDisplay preferences :vlax-true)
    
    ;; Define the new Dim3PointAngular object
    (setq AngleVertex (vlax-3d-point 0 0 0)
          FirstPoint (vlax-3d-point 2 2 0)
          SecondPoint (vlax-3d-point 1 4 0)
          TextPoint (vlax-3d-point 6 6 0))

    ;; Create the new Dim3PointAngular object in model space
    (setq modelSpace (vla-get-ModelSpace doc))  
    (setq DimPointAngularObj (vla-AddDim3PointAngular modelSpace AngleVertex FirstPoint SecondPoint TextPoint))
    (vla-ZoomAll acadObj)

    ;; Read and display current dimension lineweight
    (setq CurrentSetting (vla-get-DimensionLineWeight DimPointAngularObj))
    (cond
        ((= acLnWtByLayer CurrentSetting)(setq CurrentSetting "ByLayer"))
        ((= acLnWtByBlock CurrentSetting)(setq CurrentSetting "ByBlock"))
        ((= acLnWtByLwDefault CurrentSetting)(setq CurrentSetting "ByDefault"))
	(setq CurrentSetting (itoa CurrentSetting))
    )
  
    (alert (strcat "The dimension lineweight setting for this object is currently set to: " CurrentSetting))

    ;; Change the dimension lineweight
    (vla-put-DimensionLineWeight DimPointAngularObj acLnWt100)
    (vla-Regen doc acAllViewports)
    
    ;; Read and display current dimension lineweight
    (alert (strcat "The dimension lineweight setting for this object is now set to: " (itoa (vla-get-DimensionLineWeight DimPointAngularObj))))
    
    ;; Return previous lineweight setting
    (vla-put-DimensionLineWeight DimPointAngularObj oldLWSetting)
)