Specifies the vertical justification of tolerance values relative to the nominal dimension text.
Supported platforms: Windows only
VBA:
object.ToleranceJustification
Type: Dim3PointAngular, DimAligned, DimAngular, DimArcLength, DimDiametric, Dimension, DimOrdinate, DimRadial, DimRadialLarge, DimRotated
The objects this property applies to.
Read-only: No
Type: acDimToleranceJustify enum
The initial value for this property is acTolMiddle.
This property is only available when the ToleranceDisplay property is set to any value other than acTolNone.
VBA:
Sub Example_ToleranceJustification() ' This example creates an aligned dimension in model space and ' sets the tolerance justification for the dimension to ' a couple of common values ' ' * Note the vertical position of the tolerance text Dim dimObj As AcadDimAligned Dim newText As AcadTextStyle Dim point1(0 To 2) As Double, point2(0 To 2) As Double Dim location(0 To 2) As Double Dim CurrentDisplay As String ' Define the dimension point1(0) = 5: point1(1) = 5: point1(2) = 0 point2(0) = 5.5: point2(1) = 5: point2(2) = 0 location(0) = 5: location(1) = 7: location(2) = 0 ' Create an aligned dimension object in model space Set dimObj = ThisDrawing.ModelSpace.AddDimAligned(point1, point2, location) ' Turn on tolerance display and increase the dimension text height, ' so the alignment of the tolerance is visible dimObj.ToleranceDisplay = acTolSymmetrical dimObj.textHeight = 1 dimObj.ToleranceHeightScale = 0.25 ThisDrawing.Application.ZoomAll ' Read and display the current tolerance justification for this dimension Select Case dimObj.ToleranceJustification Case acTolBottom: CurrentDisplay = "Bottom" Case acTolTop: CurrentDisplay = "Top" Case acTolMiddle: CurrentDisplay = "Middle" End Select MsgBox "The tolerance justification is currently: " & CurrentDisplay ' Set the tolerance justification for this dimension dimObj.ToleranceJustification = acTolBottom ThisDrawing.Regen acAllViewports ' Display the current tolerance justification for this dimension MsgBox "The tolerance display is now set to: Bottom" End Sub
Visual LISP:
(vl-load-com) (defun c:Example_ToleranceJustification() ;; This example creates an aligned dimension in model space and ;; sets the tolerance justification for the dimension to ;; a couple of common values ;; ;; * Note the vertical position of the tolerance text (setq acadObj (vlax-get-acad-object)) (setq doc (vla-get-ActiveDocument acadObj)) ;; Define the dimension (setq point1 (vlax-3d-point 5 5 0) point2 (vlax-3d-point 5.5 5 0) location (vlax-3d-point 5 7 0)) ;; Create an aligned dimension object in model space (setq modelSpace (vla-get-ModelSpace doc)) (setq dimObj (vla-AddDimAligned modelSpace point1 point2 location)) ;; Turn on tolerance display and increase the dimension text height, ;; so the alignment of the tolerance is visible (vla-put-ToleranceDisplay dimObj acTolSymmetrical) (vla-put-TextHeight dimObj 1) (vla-put-ToleranceHeightScale dimObj 0.25) (vla-ZoomAll acadObj) (vla-Regen doc acAllViewports) ;; Read and display the current tolerance justification for this dimension (setq currentDisplay (cond ((= (vla-get-ToleranceJustification dimObj) acTolBottom) "Bottom") ((= (vla-get-ToleranceJustification dimObj) acTolTop) "Top") ((= (vla-get-ToleranceJustification dimObj) acTolMiddle) "Middle") )) (alert (strcat "The tolerance justification is currently: " currentDisplay)) ;; Set the tolerance justification for this dimension (vla-put-ToleranceJustification dimObj acTolBottom) (vla-Regen doc acAllViewports) ;; Display the current tolerance justification for this dimension (alert "The tolerance display is now set to: Bottom") )