unload_dialog (AutoLISP/DCL)

Unloads a DCL file

Supported Platforms: Windows and Mac OS

Signature

(unload_dialog dcl_id)
dcl_id

Type: Integer

A DCL file identifier obtained from a previous load_dialog call.

Return Values

Type: nil

Always returns nil.

Remarks

Unloads the DCL file associated with dcl_id (obtained from a previous new_dialog call) from memory.

While it isn't necessary to unload a DCL definition from memory, it is recommended to unload DCL definitions when they aren't needed. Unloading DCL files helps to free up system resources and allows you to update a DCL dialog definition from a new file.

Note: DCL on Mac OS uses more memory than on Windows, unload DCL file definitions that are not needed to avoid running low on memory.

Release Information

Examples

N/A