Dialog Box Opening and Closing Functions Reference (AutoLISP/DCL)

The following table provides summary descriptions of the DCL opening and closing functions.

Dialog box opening and closing functions

Function name

Description

(done_dialog [status])

Terminates a dialog box

(load_dialog dclfile)

Loads a DCL file

(new_dialog dlgname dcl_id [action [screen-pt]])

Begins a new dialog box and displays it, and can also specify a default action

(start_dialog)

Displays a dialog box and begins accepting user input

(term_dialog)

Terminates all current dialog boxes as if the user cancels each of them

(unload_dialog dcl_id)

Unloads a DCL file