load_dialog (AutoLISP/DCL)

Loads a DCL file

Supported Platforms: Windows and Mac OS

Signature

(load_dialog dclfile)
dclfile

Type: String

DCL file to load. If the dclfile argument does not specify a file extension, .dcl is assumed.

Return Values

Type: Integer

A positive integer value (dcl_id) if successful, or a negative integer if load_dialog cannot open the file. The dcl_id is used as a handle in subsequent new_dialog and unload_dialog calls.

Remarks

The load_dialog function searches for files according to the AutoCAD library search path.

This function is the complement of unload_dialog. An application can load multiple DCL files with multiple load_dialog calls.

Release Information

Examples

N/A