action_tile (AutoLISP/DCL)

Assigns an action to evaluate when the user selects the specified tile in a dialog box

Supported Platforms: Windows and Mac OS

Signature

(action_tile key action-expression)
key

Type: String

Names the tile that triggers the action (specified as its key attribute). This argument is case-sensitive.

action-expression

Type: String

Expression evaluated when the tile is selected.

Return Values

Type: T or nil

T if the key was found; otherwise it returns nil.

Remarks

The action assigned by action_tile supersedes the dialog box's default action (assigned by new_dialog) or the tile's action attribute, if these are specified. The expression can refer to the tile's current value as $value, its name as $key, its application-specific data (as set by client_data_tile) as $data, its callback reason as $reason, and its image coordinates (if the tile is an image button) as $x and $y.

Note: You cannot call the AutoLISP command function from the action_tile function.

Release Information

Examples

If edit1 is a text box, the action expression in the following action_tile call is evaluated when the user exits the text box:

(action_tile "edit1" "(setq ns $value)")