The Properties palette API includes interfaces and implementation classes that provide access to the Properties palette window. These APIs can be used in conjunction with the Property Inspector APIs to achieve comprehensive control over the Properties palette environment.
A complete, categorized list of Property Inspector and Properties palette API interfaces and classes can be found in the Properties Palette Interfaces and Classes section at the end of this chapter.
The following table lists the header files that contain Properties palette declarations, with a summary of their contents.
Properties Palette Header and Declaration Files |
|
---|---|
Filename |
Contents |
axtempl.h |
Provides ATL-based template class implementations that wrap the IAcadBaseObject, IAcadBaseObject2, ICategorizeProperties, IAcPiCategorizeProperties, AcPiPropCommandButtons, IAcPiPropertyDisplay, IIOPMPropertyExtension, and IPerPropertyBrowsing interfaces |
AcPp.h, AcPp_i.c |
Properties palette (IAcPp*) interfaces; MIDL-generated header file containing declarations for Automation interfaces described in AcPp16.tlb |
opmdialog.h |
Provides declarations for IOPMPropertyDialog and IOPMPropertyDialog2 COM interfaces |
opmdrvr.h |
Provides declarations for global functions used internally by the Properties palette's ATL-based template class implementations |
opmext.h |
Provides declarations for IOPMPropertyExtension, IOPMPropertyExpander, and IOPMPropertyExpander2 COM interfaces |
opmimp.h |
Provides declarations for macros used by the Properties palette's ATL-based template class implementations |