Property Inspector API

The Property Inspector API presents a large array of COM interfaces, ATL-based implementation classes, and shortcut macros. A categorized list of interfaces and classes can be found in the Properties Palette Interfaces and Classes section at the end of this chapter.

Declarations for these elements are divided between a number of header files. The following table lists the names of files that contain Property Inspector API declarations, with a summary of their contents.

Properties Palette Header and Declaration Files 

 

Filename

Contents

axboiler.h

Provides interface declarations for IAcadBaseObject and IAcadBaseObject2, as well as global functions for dealing with both database-resident entities and non-database-resident objects through COM; for use only with objects derived from AcDbObject

axtempl.h

Provides ATL-based template class implementations that wrap the IAcadBaseObject, IAcadBaseObject2, ICategorizeProperties, IAcPiCategorizeProperties, AcPiPropCommandButtons, IAcPiPropertyDisplay, IIOPMPropertyExtension, and IPerPropertyBrowsing interfaces

category.h

Provides declarations of standard property category identifiers and the ICategorizeProperties COM interfaces

acpexctl.h, acpexctl_i.c

Property Edit stock control (IAcPe*) interfaces; MIDL-generated files containing declarations for Automation interfaces described in AcPEXCtl16.tlb

acpi.h, acpi_i.c

Property Inspector (IAcPi*) interfaces; MIDL-generated files containing declarations for Automation interfaces described in AcPi16.tlb

dynpropmgr.h

Provides the AcRxDynPropManager class definition

dynprops.h

Provides declarations for dynamic property and dynamic property manager interfaces, per-instance dynamic property classes, and dynamic property macros