新的 AutoCAD 命令和系统变量参考

提供快速指南,说明在此版本中新增了哪些命令。

AutoCAD 2025.1 新命令和系统变量

新系统变量 说明 AutoCAD AutoCAD LT
MLEADERLAYER 指定新多重引线的默认图层。 ✓ ✓
BCONVERTINCLUDEEXISTINGBLOCKS 控制默认情况下是否通过 BCONVERT 命令选择现有块实例。用户仍可以在审阅过程中对选择进行调整。 ✓ ✓

AutoCAD 2025 新命令和系统变量

新命令 说明 AutoCAD AutoCAD LT
ACTIVITYINSIGHTSCLOSE 关闭“活动见解”选项板。
注: 现在,在 AutoCAD LT 中可用。
✓ ✓
ACTIVITYINSIGHTSOPEN 打开“活动见解”选项板,从中可以查看您或其他人过去在图形中执行的操作。
注: 现在,在 AutoCAD LT 中可用。
✓ ✓
BCONVERT

-BCONVERT

将选定的几何图形和相同实例转换为块。 ✓ ✓
DETECT 显示“检测”选项板并启动对象检测。 ✓
DETECTCLOSE 结束检测检查。 ✓
DETECTCONVERT 显示“转换”对话框,在其中可以将亮显的实例转换为块。 ✓
DETECTPRIMARY 指定从中创建新块定义的检测到的实例。 ✓
DETECTREMOVE 从集中删除选定实例。 ✓
DETECTREVIEWNEXT 显示下一组检测到的对象。 ✓
DETECTREVIEWPREV 显示上一组检测到的对象。 ✓
新系统变量 说明 AutoCAD AutoCAD LT
ACTIVITYINSIGHTSSTATE 指示“活动见解”选项板是处于打开状态还是关闭状态。
注: 现在,在 AutoCAD LT 中可用。
✓ ✓
ACTIVITYINSIGHTSSUPPORT 启用或禁用“活动见解”功能。
注: 现在,在 AutoCAD LT 中可用。
✓ ✓
BLOCKEXCLUDECOLOR 为不应该转换为块的识别实例设置亮显颜色。 ✓ ✓
BLOCKINCLUDECOLOR 为可以转换为块的识别实例设置亮显颜色。 ✓ ✓
BLOCKTARGETCOLOR 为从中创建新块定义的指定实例设置亮显颜色。 ✓ ✓
ENABLESYNCPDF 控制在使用 AutoCAD PDF 绘图仪配置之一打印或发布保存到 Autodesk Docs 的图形时,AutoCAD 是否嵌入这些图形的源图形信息。 ✓
DX12FRAMERATEUNLIMITED 启用变量同步监视器优化。 ✓ ✓
HPDRAWMODE 控制定义要填充图案或填充的新边界时使用的绘图模式。 ✓ ✓
HPPATHALIGNMENT 指定要填充图案或填充的新绘制路径的路线。 ✓ ✓
HPPATHWIDTH 指定要填充图案或填充的新绘制路径的宽度。 ✓ ✓
TRACEVPSUPPORT
AutoCAD
控制标记框在当前活动模型空间视口中是否可操作。
AutoCAD LT
控制是否可以复制跟踪几何图形,或是否将其用于活动视口中的对象捕捉。
注: 现在,在 AutoCAD LT 中可用。
✓ ✓

AutoCAD 2024.1 新命令和系统变量

新命令 说明 AutoCAD AutoCAD LT
ASSISTANTCLOSE 关闭“Autodesk Assistant”选项板。 ✓ ✓
ASSISTANTOPEN 显示“Autodesk Assistant”选项板,可以在其中搜索多个来源的帮助、联系技术支持或提供反馈。 ✓ ✓
新系统变量 说明 AutoCAD AutoCAD LT
ASSISTANTSTATE 指示“Autodesk Assistant”选项板是处于打开、关闭还是隐藏状态。 ✓ ✓

AutoCAD 2024 新命令和系统变量

新命令 说明 AutoCAD AutoCAD LT
ACTIVITYINSIGHTSCLOSE 关闭“活动见解”选项板。 ✓
ACTIVITYINSIGHTSOPEN 打开“活动见解”选项板,从中可以查看您或其他人过去在图形中执行的操作。 ✓
BLOCKSDATAOPTION 显示“数据收集同意”对话框。 ✓
BREPLACE 将选定块参照替换为其他块。建议使用类似的块进行替换。 ✓
-BREPLACE 在命令提示下,将现有块替换为指定块。 ✓
COPYFROMTRACE 将对象从跟踪中复制到图形中。 ✓ ✓
FADEMARKUP

-FADEMARKUP

淡显各个标记,以便降低它们在跟踪中的能见度。 ✓
新系统变量 说明 AutoCAD AutoCAD LT
ACTIVITYINSIGHTSPATH 指定“活动见解”事件日志文件写入到(或复制到)的路径。 ✓ ✓
ACTIVITYINSIGHTSSTATE 指示“活动见解”选项板是处于打开状态还是关闭状态。 ✓
ACTIVITYINSIGHTSVIEWEDLOGGING 打开/关闭“已查看”事件的日志记录。 ✓ ✓
AUTOPLACEMENT 控制插入块时是否显示放置建议。 ✓ ✓
BLOCKSDATACOLLECTION 控制是否将块替换期间使用的内容数据发送给数据收集服务。 ✓
COMMENTHIGHLIGHT 控制 PDF 文字注释上指示器标记的显示。 ✓
MARKUPSELECTIONMODE 允许使用边界标记边框作为条件进行选择。 ✓
PLACEMENTSWITCH 指示在插入块时是否默认显示放置建议。 ✓ ✓
TRACEMARKUPFADECTL 控制已淡显标记的透明度。数字越小,标记越明显。 ✓
TRACEVPSUPPORT 控制标记框在当前活动模型空间视口中是否可操作。 ✓

AutoCAD 2023.1 版新的命令和系统变量

新命令 说明 AutoCAD AutoCAD LT
PERFANALYZER 打开“性能分析器”选项板,在其中可以诊断 AutoCAD 中看似缓慢或无响应的操作。 ✓
PERFANALYZERCLOSE 关闭“性能分析器”选项板。 ✓

AutoCAD 2023 版本中的新命令和系统变量

新命令 说明 AutoCAD AutoCAD LT
ARCTEXT 沿圆弧放置文字。
注: 现在适用于 AutoCAD LT。
✓ ✓
COMMANDMACROS 打开可以管理和使用命令宏建议的“命令宏”选项板。 ✓
COMMANDMACROSCLOSE 关闭“命令宏”选项板。 ✓
COUNTAREA 定义要计数对象或块实例的区域。
注: 仅在计数处于活动状态时可用。
✓ ✓
COUNTAREACLOSE 取消计数选择区域。
注: 仅在计数处于活动状态时可用。
✓ ✓
CUTBASE 将选定对象与指定的基点一起复制到剪贴板,并将它们从图形中删除。 ✓ ✓
MARKUPASSIST

-MARKUPASSIST

分析输入的标记,有助于以较少的手动操作更快地放置文字标注和修订云线。 ✓
MARKUPIMPORT

-MARKUPIMPORT

将标记的图形(图像/PDF)在位输入到 DWG 中作为新跟踪。 ✓
SELECTCOUNT 在当前计数内查找与选定对象的特性匹配的所有对象,然后将它们添加到选择集中。
注: 仅在计数处于活动状态时可用。
✓ ✓
TRACEEDIT 将活动跟踪更改为编辑模式。
注: 仅在跟踪处于活动状态时可用。
✓ ✓
TRACEVIEW 将活动跟踪更改为查看模式。
注: 仅在跟踪处于活动状态时可用。
✓ ✓
新系统变量 说明 AutoCAD AutoCAD LT
ANNOSCALEZOOM 控制图纸空间视口中的鼠标滚轮缩放是由特定缩放比例控制还是独立的(旧版行为)。 ✓ ✓
COMMANDMACROSSTATE 指示“命令宏”选项板是处于“打开”状态还是“关闭”状态。 ✓
FASTSHADEDMODE 指定新的跨平台三维图形系统是处于“打开”状态还是“关闭”状态。 ✓
JIGZOOMMAX 控制块范围在插入时必须适配的视图标注的最大百分比。 ✓ ✓
JIGZOOMMIN 控制块范围在插入时必须适配的视图标注的最小百分比。 ✓ ✓
MACROINSIGHTSSUPPORT 控制是否可以根据您执行的命令序列接收宏见解。 ✓
MACRONOTIFY 控制宏见解的通知。 ✓
MARKUPASSISTMODE 控制是否亮显识别的标记。 ✓
MARKUPPAPERDISPLAY 指示数字标记当前是否处于活动状态。 ✓
MARKUPPAPERTRANSPARENCY 控制数字标记处于活动状态时的透明度级别。 ✓
PASTESPECMODE 将 PASTESPEC 命令与“AutoCAD 图元”选项一起使用时,控制 Microsoft Excel 数据的单元格格式设置。 ✓ ✓
SSMDETECTMODE 确定打开基于云的 DST 文件时显示的图纸集管理器。 ✓ ✓
STYLUSFORCETHRESHOLD 控制光笔压力阈值。 ✓ ✓

AutoCAD 2022.1 新命令和系统变量

新系统变量 说明 AutoCAD AutoCAD LT
DISPSILHBLOCKS 控制块中三维实体轮廓在二维线框视觉样式中的显示。 ✓ ✓

AutoCAD 2022 新命令和系统变量

新命令 说明 AutoCAD AutoCAD LT
COUNT 计数并亮显图形中选定对象的实例。 ✓ ✓
COUNTCLOSE 关闭“计数”工具栏并结束计数。 ✓ ✓
COUNTFIELD 创建设置为当前计数值的字段。 ✓ ✓
COUNTLIST 打开“计数”选项板以查看和管理计数的块。 ✓ ✓
COUNTLISTCLOSE 关闭“计数”选项板。 ✓ ✓
COUNTNAVNEXT 缩放到计数结果中的下一个对象。 ✓ ✓
COUNTNAVPREV 缩放到计数结果中的上一个对象。 ✓ ✓
COUNTTABLE 在图形中插入包含块名称和每个块的相应计数的表格。 ✓ ✓
PURGEAECDATA 在命令提示下删除图形中不可见的 AEC 数据(AutoCAD Architecture 和 AutoCAD Civil 3D 自定义对象)。 ✓ ✓
PUSHTODOCSOPEN 打开“推送到 Autodesk Docs”选项板,从中可以选择要作为 PDF 上载到 Autodesk Docs 的 AutoCAD 布局。 ✓ ✓
PUSHTODOCSCLOSE 关闭“推送到 Autodesk Docs”选项板。 ✓ ✓
SHARE 共享指向当前图形副本的链接,以在 AutoCAD Web 应用程序中查看或编辑。图形副本包含所有外部参照和图像。 ✓ ✓
TRACE 从命令提示打开和管理跟踪。
注: 在 AutoCAD Web 应用程序或 AutoCAD 移动应用程序中创建跟踪,以提供图形的反馈、注释、标记和设计探索,而不会更改图形的内容。
✓ ✓
TRACEBACK 以完全饱和度显示宿主图形,同时暗显跟踪几何图形。 ✓ ✓
TRACEFRONT 以完全饱和度显示活动跟踪,同时暗显宿主图形几何图形。 ✓ ✓
TRACEPALETTECLOSE 关闭“跟踪”选项板。 ✓ ✓
TRACEPALETTEOPEN 打开“跟踪”选项板以查看当前图形中可用的跟踪。 ✓ ✓
新系统变量 说明 AutoCAD AutoCAD LT
BGCOREPUBLISH 控制后台发布是使用单核还是多核。 ✓ ✓
BLOCKCREATEMODE 在使用 BLOCK 和 -BLOCK 命令创建块后,设置选定对象的行为。 ✓ ✓
CLOUDCOLLABMODIFIEDOPTION 控制文档(DWG 和 DWT 文件)在 AutoCAD 中关闭后何时在 BIM 360 中解锁。 ✓ ✓
COUNTCHECK 控制对计数中错误的检查。 ✓ ✓
COUNTCOLOR 设置计数中对象的亮显颜色。 ✓ ✓
COUNTERRORCOLOR 对在计数中可能造成潜在错误的对象设置亮显颜色。 ✓ ✓
COUNTERRORNUM 显示当前计数中的错误数量。 ✓ ✓
COUNTNUMBER 显示当前计数的数量。 ✓ ✓
COUNTPALETTESTATE 报告“计数”选项板是处于打开状态还是关闭状态。 ✓ ✓
COUNTSERVICE 控制计数的后台索引。 ✓ ✓
ENABLEDSTLOCK 控制从 BIM 360 打开图纸集 (DST) 文件后是否自动锁定该文件。 ✓ ✓
MTEXTEDENCODING 设置在编辑多行文字的同时从外部编辑器读取输出时要使用的所需编码。 ✓ ✓
PUSHTODOCSSTATE 指示“推送到 Autodesk Docs”选项板是处于打开状态还是处于关闭状态。 ✓ ✓
SYSFLOATING 控制图形窗口选项卡的固定状态。 ✓ ✓
TRACECURRENT 当 TRACEMODE=1 或 2 时,显示活动跟踪的名称。 ✓ ✓
TRACEDISPLAYMODE 当跟踪处于活动状态时,指示跟踪图纸效果是处于显示状态(前)还是处于不显示状态(后)。 ✓ ✓
TRACEFADECTL 当 TRACEMODE 处于活动状态时,控制淡显程度。该设置仅影响不在进行编辑的对象 - 宿主图形几何图形或跟踪几何图形。 ✓ ✓
TRACEMODE 指示跟踪是否处于活动状态以及当前所处模式。 ✓ ✓
TRACEOSNAP 控制在查看跟踪时对象捕捉是否应用于跟踪几何图形。 ✓ ✓
TRACEPALETTESTATE 报告“跟踪”选项板是处于打开状态还是处于关闭状态。 ✓ ✓
TRACEPAPERCTL 控制跟踪图纸效果的不透明度。 ✓ ✓
WBLOCKCREATEMODE 在将块另存为文件后,使用 WBLOCK 和 -WBLOCK 命令设置选定对象的行为。 ✓ ✓

AutoCAD 2021.1 新命令和系统变量

新系统变量 说明 AutoCAD AutoCAD LT
BLOCKSYNCFOLDER 设置存储最近使用的块和收藏块的路径。 ✓ ✓

AutoCAD 2021 新命令和系统变量

新命令 说明 AutoCAD AutoCAD LT
BREAKATPOINT 在指定点处将选定对象打断为两个对象。 ✓ ✓

DWGHISTORY

打开“图形历史记录”选项板,其中显示了由支持的云存储提供程序维护的当前图形的版本历史记录。 ✓ ✓

DWGHISTORYCLOSE

关闭“图形历史”选项板。 ✓ ✓
-INSERTCONTENT 将图形或块插入到当前图形中。 ✓ ✓
MAKELISPAPP 将一个或多个 AutoLISP (LSP) 源文件编译到可分发给用户并保护代码的应用程序 (VLX) 文件中。 ✓
-PAGESETUP PAGESETUP 命令的命令行版本,用于替代脚本和其他自定义中页面设置的设置。 ✓ ✓
REVCLOUDPROPERTIES 控制选定修订云线中圆弧的近似弦长。 ✓ ✓
XCOMPARE 将附着的外部参照与参照图形文件的最新状态相比较,在修订云线内使用颜色亮显差异。 ✓ ✓
XCOMPARECLOSE 关闭“外部参照比较”工具栏并结束比较。 ✓ ✓
XCOMPARERCNEXT 缩放到外部参照比较结果的下一更改集。 ✓ ✓
XCOMPARERCPREV 缩放到外部参照比较结果的上一更改集。 ✓ ✓
新系统变量 说明 AutoCAD AutoCAD LT
BLOCKSRECENTFOLDER 设置存储最近插入或创建的块的路径。 ✓ ✓
COMPARESHOWCONTEXT 控制外部参照比较中未使用的对象的可见性。 ✓ ✓

DWGHISTORYSTATE

报告“图形历史记录”选项板是处于打开还是关闭状态。 ✓ ✓
LISPSYS 控制使用 VLISP 命令启动的默认 AutoLISP 开发环境。 ✓
REVCLOUDAPPROXARCLEN 存储修订云线的当前近似弧长。 ✓ ✓
REVCLOUDARCVARIANCE 控制是使用不同弦长还是均匀弦长创建修订云线圆弧。 ✓ ✓
RTREGENAUTO 控制实时平移和缩放操作中的自动重新生成。 ✓ ✓
TEXTGAPSELECTION 控制是否可以在字符之间的间隙或空格内选择文字对象或多行文字对象。默认情况下,此系统变量处于禁用状态。 ✓ ✓
TRIMEDGES 控制使用“快速”模式修剪和延伸到图案填充的操作是限于图案填充的边缘,还是包括填充图案范围内的对象。 ✓ ✓
TRIMEXTENDMODE 控制 TRIM 和 EXTEND 命令是否默认使用简化的输入。 ✓ ✓
XCOMPAREBAKPATH 指定存储备份外部参照文件的路径。 ✓ ✓
XCOMPAREBAKSIZE 设置存储备份外部参照文件的文件夹的大小。 ✓ ✓
XCOMPARECOLORMODE 在外部参照比较期间切换对象在宿主图形中的视觉效果。 ✓ ✓
XCOMPAREENABLE 支持在外部参照和参照图形文件之间进行比较。 ✓ ✓

AutoCAD 2020.1 新命令和系统变量

新命令 说明 AutoCAD AutoCAD LT
无
新系统变量 说明 AutoCAD AutoCAD LT
TEXTLAYER 为当前图形中新的文字对象和多行文字对象指定默认图层。 ✓ ✓

AutoCAD 2020 新命令和系统变量

新命令 说明 AutoCAD AutoCAD LT
BLOCKSPALETTE 打开“块”选项板。 ✓ ✓
BLOCKSPALETTECLOSE 关闭“块”选项板。 ✓ ✓
CLASSICINSERT 打开经典“插入”对话框。 ✓ ✓
COMPARECLOSE 关闭“比较”工具栏并退出比较。 ✓ ✓
COMPAREEXPORT 将比较结果输出到称为“快照图形”的新图形中,然后打开该图形。 ✓ ✓
COMPAREIMPORT 将比较文件中的对象输入到当前图形中。仅输入比较文件中存在而当前文件中不存在的选定对象。 ✓ ✓
新系统变量 说明 AutoCAD AutoCAD LT
BLOCKMRULIST 控制在“块”选项板的“最近使用”选项卡中显示的最近使用块的数量。 ✓ ✓
BLOCKNAVIGATE 控制“块”选项板的“其他图形”选项卡中显示的文件和块。 ✓ ✓
BLOCKREDEFINEMODE 控制从“块”选项板插入块(其名称与当前图形中块的名称相同)时是否显示对话框。 ✓ ✓
BLOCKSTATE 报告“块”选项板是处于打开状态还是关闭状态。 ✓ ✓

AutoCAD 2019 新命令和系统变量

新命令 说明 AutoCAD AutoCAD LT
COMPARE 比较并亮显相同图形或不同图形的两个版本之间的差异。 ✓ ✓
-COMPARE 使用“命令”窗口,比较并亮显相同图形或不同图形的两个版本之间的差异。 ✓ ✓
COMPAREINFO 允许插入或复制有关两个比较图形文件的特性信息。 ✓ ✓
OPENFROMWEBMOBILE 从联机 Autodesk Web 和 Mobile 帐户打开图形文件。 ✓ ✓
SAVETOWEBMOBILE 将当前图形的副本保存到联机 Autodesk Web 和 Mobile 帐户。 ✓ ✓
SHAREDVIEWS 打开“共享视图”选项板。 ✓ ✓
SHAREDVIEWSCLOSE 关闭“共享视图”选项板。 ✓ ✓
SHAREVIEW 创建当前空间或整个图形的表示,以供联机查看和共享。 ✓ ✓
-SHAREVIEW 使用“命令”窗口,创建当前空间或整个图形的表示,以供联机查看和共享。 ✓ ✓
新系统变量 说明 AutoCAD AutoCAD LT
COMPARECOLOR1 设置结果比较图形文件中仅在第一个图形中存在的对象的颜色。 ✓ ✓
COMPARECOLOR2 设置结果比较图形文件中仅在第二个图形中存在的对象的颜色。 ✓ ✓
COMPARECOLORCOMMON 设置进行比较的两个图形中相同对象的颜色。 ✓ ✓
COMPAREFRONT 控制比较结果图形中重叠对象的默认显示次序。 ✓ ✓
COMPAREHATCH 控制是否在图形比较中包含图案填充对象。 ✓ ✓
COMPAREPROPS 控制是否将非几何(显示)特性中的更改标识为两个图形版本之间的更改。 ✓ ✓
COMPARERCMARGIN 指定自修订云线(包含比较结果图形中对象的差异)的边界框的偏移距离。 ✓ ✓
COMPARERCSHAPE 控制是否在比较结果图形中将附近的单个更改合并为一个较大的矩形或一系列较小的矩形。 ✓ ✓
COMPARESHOW1 显示仅在第一个图形中存在的对象。 ✓ ✓
COMPARESHOW2 显示仅在第二个图形中存在的对象。 ✓ ✓
COMPARESHOWCOMMON 显示进行比较的两个图形中相同的对象。 ✓ ✓
COMPARESHOWRC 在比较结果图形中显示差异周围的修订云线。 ✓ ✓
COMPARETEXT 控制是否在图形比较中包含文字对象。 ✓ ✓
COMPARETOLERANCE 指定在比较两个图形文件时使用的容差 - 如果实体低于或等于指定的小数点值,则认为它们是相同的。 ✓ ✓
FILLETPOLYARC 确定多段线(包括当前圆弧或旧圆弧)的圆角行为。仅影响 FILLET 命令的“多段线”选项。 ✓ ✓
MVIEWPREVIEW 控制插入命名或新布局视口时的预览行为。 ✓ ✓
SECUREREMOTEACCESS 控制是否限制从 Internet 位置或远程服务器访问文件。 ✓ ✓
SHAREVIEWPROPERTIES 控制共享视图是否包含图形特性。 ✓ ✓
SHAREVIEWTYPE 控制是从当前视图、模型空间或某一布局中创建共享视图,还是从整个图形中创建共享视图。 ✓ ✓
STUDENTDRAWING 报告当前图形是否已与 Autodesk 学生版产品一起保存。 ✓ ✓

AutoCAD 2018.1 新命令和系统变量

新命令 说明 AutoCAD AutoCAD LT
NEWVIEW 基于当前视口中显示的内容或通过定义矩形窗口,来保存新的命名视图。(已添加到 AutoCAD LT) ✓ ✓
新系统变量 说明 AutoCAD AutoCAD LT
LAYEROVERRIDEHIGHLIGHT 针对具有替代的图层切换背景色亮显的可见性。 ✓ ✓
THUMBSIZE2D 控制使用二维线框视觉样式的图形缩略图预览的显示分辨率是否设置为 256 x 256 像素。 ✓ ✓
VISRETAINMODE 当 VISRETAIN 系统变量设置为 1 时,控制其行为。 ✓ ✓
XREFLAYER 为新的外部参照指定默认图层。 ✓ ✓

AutoCAD 2018 新命令和系统变量

新命令 说明 AutoCAD AutoCAD LT
APPSTORE 打开 Autodesk App Store 网站。命令以前名为“EXCHANGE”。 ✓
新系统变量 说明 AutoCAD AutoCAD LT
PDFSHX 控制是否在将图形输出为 PDF 文件时,将使用 SHX 字体的文字对象存储在 PDF 文件中作为注释。
注: 从 EPDFSHX 重命名以保持一致性。
✓ ✓
MILLISECS 存储自系统启动后已经过的毫秒数。
注: 当需要计算几分之一秒的时间差时,请使用此系统变量。
✓ ✓
PDFSHXBESTFONT 在将输入的 PDF 几何图形转换为文字时,控制 PDFSHXTEXT 命令使用最佳匹配字体或使用超过识别阈值的第一个选定字体。 ✓ ✓
REFPATHTYPE 控制当参照文件第一次附着到宿主图形文件时是使用完整路径、相对路径还是无路径。 ✓ ✓
SELECTIONOFFSCREEN 控制屏幕外对象的选择。 ✓ ✓
XREFLAYER 为新的外部参照指定默认图层。 ✓ ✓
XREFREGAPPCTL 控制存储在加载的外部参照中的已注册应用程序 (RegApp) 记录是否将复制到宿主图形中。 ✓

AutoCAD 2017.1 新命令和系统变量

新命令 说明 AutoCAD AutoCAD LT
HIGHLIGHTNEW 控制是否使用橙色点在用户界面中亮显产品更新中的新功能。 ✓ ✓

ONLINEDESIGNSHARE

将当前图形的设计视图发布到安全、匿名 Autodesk A360 位置,以供在 Web 浏览器中查看和共享。 ✓ ✓
PDFSHXTEXT 将从 PDF 文件中输入的 SHX 几何图形转换为单个多行文字对象。 ✓ ✓
-PDFSHXTEXT 通过命令行,将从 PDF 文件中输入的 SHX 几何图形转换为单个多行文字对象。 ✓ ✓
REGEN3 在图形中重新生成视图,以修复三维实体和曲面显示中的异常问题。 ✓
TXT2MTXT 将单行或多行文字对象转换或者合并为一个或多个多行文字对象。 ✓ ✓
新系统变量 说明 AutoCAD AutoCAD LT
EPDFSHX 控制是否在将图形输出为 PDF 文件时,将使用 SHX 字体的文字对象存储在 PDF 文件中作为注释。
注: 重命名为 PDFSHX 以保持一致性。
✓ ✓
PDFSHXLAYER 控制在将 SHX 几何图形转换为文字对象时,指定给新创建的文字对象的图层。 ✓ ✓
PDFSHXTHRESHOLD 设置选定几何图形在转换为文字对象之前必须匹配某个字体的百分比。 ✓ ✓
SHOWNEWSTATE 指示更新中亮显的新功能是否处于活动状态。 ✓ ✓

AutoCAD 2017 新命令和系统变量

新命令 说明 AutoCAD AutoCAD LT
3DPRINTSERVICE 将三维模型发送到三维打印服务。 ✓
CENTERDISASSOCIATE 从中心标记或中心线定义的对象中删除其关联性。 ✓ ✓
CENTERLINE 创建与选定直线和多段线相关联的中心线几何图形。 ✓ ✓
CENTERMARK 在选定圆或圆弧的中心处创建关联的十字形标记。 ✓ ✓
CENTERREASSOCIATE 将中心标记或中心线对象关联或者重新关联到选定对象。 ✓ ✓
CENTERRESET 将中心线重置为在 CENTEREXE 系统变量中指定的当前值。 ✓ ✓
PDFIMPORT 从指定的 PDF 文件输入几何图形、填充、光栅图像和 TrueType 文字对象。 ✓ ✓
-PDFIMPORT 从指定的 PDF 文件输入几何图形、填充、光栅图像和 TrueType 文字对象。 ✓ ✓
新系统变量 说明 AutoCAD AutoCAD LT
CENTERCROSSGAP 确定中心标记与其中心线之前的间隙。 ✓ ✓
CENTERCROSSSIZE 确定关联中心标记的尺寸。 ✓ ✓
CENTEREXE 控制中心线延伸的长度。 ✓ ✓
CENTERLAYER 为新中心标记或中心线指定默认图层。 ✓ ✓
CENTERLTSCALE 设置中心标记和中心线所使用的线型比例。 ✓ ✓
CENTERLTYPE 指定中心标记和中心线所使用的线型。 ✓ ✓
CENTERLTYPEFILE 指定用于创建中心标记和中心线的已加载的线型库文件。 ✓ ✓
CENTERMARKEXE 确定中心线是否会自动从新的中心标记延伸。 ✓ ✓
CURSORTYPE 确定定点设备的光标类型。 ✓ ✓
LTGAPSELECTION 控制是否可以在使用非连续性线型定义的对象上选择或捕捉到间隙。 ✓ ✓
PDFIMPORTFILTER 控制哪些数据类型要从 PDF 文件中输入并转换为 AutoCAD 对象。 ✓ ✓
PDFIMPORTIMAGEPATH 指定在输入 PDF 文件后用于提取和保存参照图像文件的文件夹。 ✓ ✓
PDFIMPORTLAYERS 控制将哪些图层指定给输入自 PDF 文件的对象。 ✓ ✓
PDFIMPORTMODE 控制从 PDF 文件输入对象时的默认处理。 ✓ ✓
PDFSHX 控制是否在将图形输出为 PDF 文件时,将使用 SHX 字体的文字对象存储在 PDF 文件中作为注释。从 EPDFSHX 重命名以保持一致性。 ✓ ✓
PDFSHXLAYER 控制在将 SHX 几何图形转换为文字对象时,指定给新创建的文字对象的图层。 ✓ ✓
PDFSHXTHRESHOLD 设置选定几何图形在转换为文字对象之前必须匹配某个字体的百分比。 ✓ ✓
PLINEGCENMAX 设置多段线可以有的最大线段数量,以便应用程序计算几何中心。 ✓ ✓
SHOWNEWSTATE 指示更新中亮显的新功能是否处于活动状态。 ✓ ✓
TEXTEDITMODE 控制是否自动重复 TEXTEDIT 命令。 ✓ ✓

AutoCAD 2016 新命令和系统变量

新命令 说明 AutoCAD AutoCAD LT
CLOSEALLOTHER 关闭所有其他打开的图形,当前活动的图形除外。 ✓ ✓
CMATTACH

COORDINATIONMODELATTACH

将参照插入到协调模型中,例如 NWD 和 NWC Navisworks 文件。 ✓  
DIGITALSIGN 提供将数字签名添加到图形的单独命令。从 SECURITYOPTIONS 命令中删除“数字签名”选项卡。 ✓ ✓
GOTOSTART 从当前图形切换到“开始”选项卡。“开始”选项卡为“新建”选项卡的后续选项卡,并且具有不同的行为。 ✓ ✓
PCEXTRACTCENTERLINE 为点云的圆柱段绘制一条中心线。 ✓  
PCEXTRACTCORNER 标记点云中三个检测到的平面之间的交点。 ✓  
PCEXTRACTEDGE 推断两个平面之间的边,并绘制一条线来标记该边。 ✓  
PCEXTRACTSECTION 从包含截面对象的点云生成二维几何图形。 ✓  
POINTCLOUDCROPSTATE 用于保存、恢复和删除点云裁剪状态的控件。 ✓  
RENDERENVIRONMENTCLOSE 关闭“渲染环境和曝光”选项板。 ✓  
RENDEREXPOSURECLOSE 关闭“渲染环境和曝光”选项板。 ✓  
RENDERWINDOW 显示“渲染”窗口。替换 RENDERWIN 命令。 ✓  
RENDERWINDOWCLOSE 关闭“渲染”窗口。 ✓  
SCRIPTCALL 执行一系列与 SCRIPT 命令等效的命令,包括额外的执行嵌套脚本的功能。 ✓ ✓
SECTIONSPINNERS 设置“截面平面”功能区上下文选项卡中“截面偏移”和“切片厚度”的默认增量值。 ✓  
SYSVARMONITOR 显示“系统变量监视器”对话框。 ✓ ✓
新系统变量 说明 AutoCAD AutoCAD LT
CMFADECOLOR 控制所有附着的协调模型上混合的黑色量。 ✓  
CMFADEOPACITY 通过透明度控制所有附着的协调模型的暗显程度。 ✓  
CMOSNAP 确定是否为附着至图形的协调模型中的几何图形激活对象捕捉。 ✓  
DIMLAYER 为新的标注指定默认图层。 ✓ ✓
DIMPICKBOX 在 DIM 命令中设置对象选择目标高度(以像素为单位)。 ✓ ✓
DIMTXTRULER 在编辑标注文字时,控制标尺的显示。 ✓ ✓
EXPVALUE 指定渲染期间要应用的曝光值。 ✓  
EXPWHITEBALANCE 指定渲染期间要应用的开尔文颜色温度(白平衡)。 ✓  
GALLERYVIEW 控制功能区下拉库中的预览类型。 ✓ ✓
IBLENVIRONMENT 启用基于图像的照明并指定当前图像贴图。 ✓  
LEGACYCODESEARCH 控制搜索可执行文件是否包括当前文件夹和图形文件夹。 ✓  
LINEFADING 控制当硬件加速处于启用状态且已超出线密度限制时,是否淡显线显示。 ✓ ✓
LINEFADINGLEVEL 启用硬件加速后,控制线淡入效果的强度。 ✓ ✓
POINTCLOUD2DVSDISPLAY 在使用二维线宽视觉样式查看点云时,禁用或启用边界框和文字消息。 ✓  
RENDERENVSTATE 指示“渲染预设管理器”选项板是处于打开状态还是关闭状态。 ✓  
RENDERLEVEL 指定渲染引擎为创建渲染图像而执行的迭代数或层级数。 ✓  
RENDERLIGHTCALC 控制光源和材质的渲染精度。 ✓  
RENDERTARGET 控制要用于渲染的持续时间。 ✓  
RENDERTIME 指定渲染引擎用于反复细化渲染图像的分钟数。 ✓  
REVCLOUDCREATEMODE 指定用于创建修订云线的默认输入。 ✓ ✓
REVCLOUDGRIPS 控制修订云线上显示的夹点数。 ✓ ✓
SECTIONOFFSETINC 为截面对象切片厚度控件设置默认增量值。 ✓  
SECTIONTHICKNESSINC 为截面对象偏移控件设置默认增量值。 ✓  
SELECTIONEFFECTCOLOR 设置对象选择上的光晕亮显效果的颜色。 ✓ ✓
STARTINFOLDER 存储从中启动产品的驱动器和文件夹路径。 ✓ ✓
STARTMODE 控制是否显示“开始”选项卡。 ✓ ✓
SYSMON 指定是否监视对系统变量值所做的更改。 ✓ ✓
WORKINGFOLDER 存储操作系统工作文件夹的驱动器和文件夹路径,或进程的当前目录,开发人员可能对此感兴趣。 ✓ ✓
XREFOVERRIDE 控制参照图层上的对象特性的显示。 ✓ ✓

AutoCAD 2015 新命令和系统变量

新命令 说明 AutoCAD AutoCAD LT
GEOMAPIMAGE 将联机地图的一部分捕获到称为“地图图像”的对象,然后将其嵌入在绘图区域中。 ✓ ✓
GEOMAPIMAGEUPDATE 从联机地图服务重新加载地图图像并可以选择重置其分辨率,以便提供最佳的屏幕查看效果。 ✓ ✓
ISODRAFT 启用或禁用等轴测草图以及所有相关设置,然后指定当前二维等轴测草图平面。 ✓ ✓
NEWTAB 已废弃。显示一个新选项卡,用户可通过该选项卡直接访问文件、学习资源、Autodesk A360 及更多内容。 ✓ ✓
ONLINEAUTOCAD360 已废弃。在默认浏览器中启动 AutoCAD 360。 ✓ ✓
PMTOGGLE 控制是打开还是关闭性能录制器。“性能反馈”工具可用于记录性能问题,以供 Autodesk 进行分析。 ✓  
POINTCLOUDCOLORMAP 显示“点云颜色映射”对话框,用于定义强度、标高和分类点云样式化的设置。 ✓  
POINTCLOUDCROP 将选定点云裁剪为指定的多边形、矩形或圆形边界。 ✓  
POINTCLOUDMANAGER 显示“点云管理器”选项板,用于控制点云项目、面域和扫描的显示。 ✓  
POINTCLOUDMANAGERCLOSE 关闭点云管理器。 ✓  
POINTCLOUDSTYLIZE 控制点云的颜色。 ✓  
POINTCLOUDUNCROP 从选定的点云中永久删除所有裁剪区域。 ✓  
PTYPE 指定点对象的显示样式及大小。 ✓ ✓

RECAP

从 AutoCAD 中启动 Autodesk ReCap。 ✓
TEXTALIGN 垂直、水平或倾斜对齐多个文字对象。 ✓ ✓
新系统变量 说明 AutoCAD AutoCAD LT
COLORTHEME 将功能区、选项板和若干其他界面元素的颜色主题设置为深色或浅色。 ✓ ✓
COMMANDPREVIEW 控制是否显示命令的可能结果的预览。 ✓ ✓
COMPLEXLTPREVIEW 控制是否在交互式操作期间显示复杂线型的预览。 ✓ ✓
CURSORBADGE 确定是否在绘图区域中显示光标标记。 ✓ ✓
HIGHLIGHTSMOOTHING 控制对象亮显时的抗锯齿效果。 ✓ ✓
HPLINETYPE 控制非连续性线型在填充图案中的显示方式。 ✓ ✓
LAYOUTTAB 控制是否显示“模型”和“布局”选项卡。 ✓ ✓
MTEXTAUTOSTACK 控制 MTEXT 命令的自动堆叠。 ✓ ✓
MTEXTDETECTSPACE 控制是否在 MTEXT 命令中将键盘上的空格键用于创建列表项。 ✓ ✓
NEWTABMODE 已废弃。指定在文件选项卡栏上单击加号 (+) 是显示一个新选项卡还是打开一个新图形。 ✓ ✓
ORBITAUTOTARGET 控制为 3DORBIT 命令获取目标点的方式。 ✓  
OSNAPOVERRIDE 确定是否已强制使用“OSNAP”对话框中的对象捕捉设置。 ✓ ✓
PCMSTATE 指示点云管理器是处于打开状态还是关闭状态。 ✓  
POINTCLOUDLIGHTING 控制点云的光源效果的显示方式。 ✓ ✓
POINTCLOUDLIGHTSOURCE 当光源处于打开状态时,确定点云的光源。 ✓ ✓
POINTCLOUDLOD 为点云设置点显示的密度级别。 ✓ ✓
POINTCLOUDPOINTMAXLEGACY 仅适用于旧版(2015 之前)点云。设置可以为所有附着到图形的旧版点云显示的最大点数。 ✓ ✓
POINTCLOUDPOINTSIZE 控制新点云对象的点的大小。 ✓ ✓
POINTCLOUDSHADING 指定点云中的点的亮度是漫射还是镜面反射。 ✓ ✓
POINTCLOUDVISRETAIN 控制旧版图形(在 AutoCAD 2014 中创建的)是否保留单个扫描(RCS 文件)的打开或关闭状态和由附着的点云项目(RCP 文件)参照的面域。 ✓ ✓
SELECTIONEFFECT 指定对象处于选中状态时所使用的视觉效果。 ✓ ✓
SORTORDER 指定是使用自然排序顺序还是 ASCII 值来排序图层列表。 ✓ ✓
TEXTALIGNMODE 存储对齐文字的对齐选项。 ✓ ✓
TEXTALIGNSPACING 存储对齐文字的间距选项。 ✓ ✓
TEXTALLCAPS 将通过 TEXT 或 MTEXT 命令创建的所有新文字转换为大写。 ✓ ✓
TEXTAUTOCORRECTCAPS 更正因意外启用 Caps Lock 而导致的常见文字错误。 ✓ ✓

AutoCAD 2014 新命令和系统变量

新命令 说明 AutoCAD AutoCAD LT
DESIGNFEEDCLOSE 已废弃。关闭“设计提要”选项板。 ✓ ✓
DESIGNFEEDOPEN 已废弃。打开“设计提要”选项板。 ✓ ✓
FILETAB 显示位于绘图区域顶部的“文件”选项卡。 ✓ ✓
FILETABCLOSE 隐藏位于绘图区域顶部的“文件”选项卡。 ✓ ✓
GEOMAP 在当前视口中显示来自联机地图服务的地图。 ✓ ✓
GEOMARKLATLONG 将位置标记放置在由纬度和经度定义的位置上。 ✓ ✓
GEOMARKME 将位置标记放置在模型空间中与您的当前位置相对应的位置。 ✓ ✓
GEOMARKPOINT 将位置标记放置在模型空间中的指定点处。 ✓ ✓
GEOMARKPOSITION 将位置标记放置在指定的位置。 ✓ ✓
GEOREMOVE 从图形文件中删除所有地理位置信息。 ✓ ✓
GEOREORIENTMARKER 修改地理标记的方向和位置,而不更改其纬度和经度特性。 ✓ ✓
INPUTSEARCHOPTIONS 控制命令行中使用“自动完成”和“自动更正”建议的设置。 ✓ ✓
ONLINEOPENFOLDER 已废弃。在“Windows 资源管理器”或“文件资源管理器”中打开本地 Autodesk A360 文件夹。 ✓ ✓
WEBLOAD 从 URL 加载 JavaScript 文件,然后执行包含在该文件中的 JavaScript 代码。 ✓  
新系统变量 说明 AutoCAD AutoCAD LT
CGEOCS 存储指定给图形文件的 GIS 坐标系的名称。 ✓ ✓
CLAYOUT 设置当前布局。 ✓ ✓
DESIGNFEEDSTATE 已废弃。指示“设计提要”选项板是处于打开状态还是关闭状态。 ✓ ✓
DIMCONTINUEMODE 确定连续标注的样式是基于正在连续使用的标注还是当前标注样式。 ✓ ✓
FILETABPREVIEW 控制将光标悬停在文件选项卡上时预览的类型(列表视图或缩略图视图)。 ✓ ✓
FILETABSTATE 指示位于绘图区域顶部的文件选项卡的显示状态。 ✓ ✓
FILETABTHUMBHOVER 指定将光标悬停在文件选项卡缩略图上时,是否在图形窗口中加载相应的模型或布局。 ✓ ✓
GEOMARKPOSITIONSIZE 指定创建位置标记时要用于点对象和多行文字对象的比例因子。 ✓ ✓
HPPICKMODE 设置用于标识图案填充内容的默认方法是选择点还是选择对象。 ✓ ✓
INPUTSEARCHDELAY 设置显示命令行建议列表之前要延迟的毫秒数。 ✓ ✓
POINTCLOUDCACHESIZE 指定为显示点云而保留的内存量。 ✓ ✓
POINTCLOUDVISRETAIN 控制图形是否保留附着的 RCP 文件所参照的点云扫描文件的打开或关闭状态。 ✓  
SAFEMODE 指示是否可在当前 AutoCAD 任务中加载并执行可执行代码。 ✓  
SECURELOAD 控制 AutoCAD 是否根据文件的位置加载可执行文件。 ✓  
TEXTJUSTIFY 显示 TEXT 命令在创建单行文字时使用的默认对正方式。 ✓ ✓
TOUCHMODE 对于那些使用支持触摸的屏幕或界面的用户,可以控制功能区上“触摸”面板的显示。 ✓ ✓

TRUSTEDDOMAINS

控制 AutoCAD 可从中运行 JavaScript 代码的域名或 URL。 ✓  
TRUSTEDPATHS 控制 AutoCAD 可从中加载并执行包含可执行代码的文件的文件夹。 ✓  

AutoCAD 2013 新命令和系统变量

新命令 说明 AutoCAD AutoCAD LT
ARRAYCLASSIC 显示旧版“阵列”对话框。 ✓ ✓
ONLINECOLNOW 已废弃。使用 AutoCAD WS 启动联机任务,其中由您所邀请的用户可以同时查看和编辑您的当前图形。 ✓ ✓
ONLINEDOCS 已废弃。在浏览器中打开 Autodesk A360 文档列表和文件夹。 ✓ ✓
ONLINEOPTIONS 已废弃。打开“选项”对话框中的“联机”选项卡。 ✓ ✓
ONLINESHARE 已废弃。指定哪些用户可以从 Autodesk A360 访问当前文档。 ✓ ✓
ONLINESYNC 已废弃。开始或停止将自定义设置与 Autodesk A360 同步。 ✓ ✓
ONLINESYNCSETTINGS 已废弃。显示“选择要同步的设置”对话框,用户可以在其中指定要同步的选定设置。 ✓ ✓
OPENFROMCLOUD 已废弃。从本地 Autodesk A360 同步文件夹中打开现有图形文件。 ✓ ✓
POINTCLOUDCLIP 已废弃。将选定点云的显示裁剪到指定边界。 ✓  
POINTCLOUDINTENSITYEDIT 已废弃。打开“点云强度颜色映射”对话框,用于指定合格点云的强度颜色映射。 ✓  
SAVETOCLOUD 已废弃。使用新文件名将现有图形文件保存到本地 Autodesk A360 同步文件夹中。 ✓ ✓
SURFEXTRACTCURVE 从曲面提取等值线曲线。 ✓  
VIEWCOMPONENT 选择工程视图部件以进行编辑。 ✓  
VIEWDETAIL 支持通过选择现有工程视图创建局部视图。 ✓  
VIEWSECTION 支持通过选择要剖切的工程视图创建截面视图。 ✓  
VIEWDETAILSTYLE 支持创建或修改局部视图样式。 ✓  
VIEWSECTIONSTYLE 支持创建和编辑截面视图样式。 ✓  
VIEWSYMBOLSKETCH 激活视图的模型空间并进入“视图绘制”状态,来编辑和约束剖切线或详图边界。 ✓  
VIEWSKETCHCLOSE 退出“视图绘制”状态并将图纸空间置为当前。 ✓  
新系统变量 说明 AutoCAD AutoCAD LT
ANNOMONITOR 打开/关闭注释监视器。 ✓ ✓
ARRAYASSOCIATIVITY 设置要成为关联或非关联的新阵列的默认行为。 ✓ ✓
CACHEMAXFILES 为产品设置保存在本地配置的临时文件夹中的图形缓存文件的最大数量。 ✓ ✓
CACHEMAXTOTALSIZE 为产品设置保存在本地配置的临时文件夹中的图形缓存文件的最大总大小。 ✓ ✓
CLIPROMPTLINES 设置将浮动命令窗口设置为仅显示提示行时在临时提示历史记录中显示的行数。 ✓ ✓
CLIPROMPTUPDATE 控制命令行是否显示在执行 AutoLISP 或脚本文件时生成的消息和提示。 ✓ ✓
ONLINEDOCMODE 已废弃。指示图形和链接文件的副本是否会自动上传到 Autodesk A360。 ✓ ✓
ONLINESYNCTIME 已废弃。控制当前自定义设置与本地缓存同步的时间间隔,然后将其存储在 Autodesk A360 中。 ✓ ✓
PLINEREVERSEWIDTHS 控制反转多段线时多段线的外观。 ✓ ✓
POINTCLOUDBOUNDARY 打开/关闭点云边界框的显示。 ✓ ✓
POINTCLOUDCLIPFRAME 控制旧版点云上的剪裁边界是否显示在屏幕上和打印输出中。 ✓ ✓
POINTCLOUDPOINTMAX 设置图形中可存在的最大点云点数。 ✓  
PROPERTYPREVIEW 控制在将鼠标悬停在控制特性的下拉列表和库上时,是否可以预览对当前选定对象的更改。 ✓ ✓
PROPPREVTIMEOUT 设置在自动取消预览之前显示特性预览的最大秒数。 ✓  
SELECTIONPREVIEWLIMIT 限制在窗口或窗交选择期间可以显示预览亮显的对象数。 ✓ ✓
SNAPGRIDLEGACY 指定栅格捕捉仅在指定点时激活还是同时在对象选择过程中激活。 ✓  
THUMBSAVE 控制是否将 BMP 预览图像随图形一起保存。 ✓ ✓
VIEWSKETCHMODE 打开/关闭视图绘制状态。 ✓  
VIEWUPDATEAUTO 指定当更改未完成时模型文档视图是否会自动更新。 ✓  
WIPEOUTFRAME 控制区域覆盖对象的框架的显示。 ✓ ✓