Gets the object ID of the owner (parent) object for 64-bit systems. (Obsolete)
Supported platforms: Windows only
VBA:
object.OwnerID32
Type: All Drawing objects, AttributeReference, Block, Blocks, Dictionary, Dictionaries, Dimension, DimStyle, DimStyles, Group, Groups, Layer, Layers, Layout, Layouts, Linetype, Linetypes, Material, Materials, MLeaderStyle, ModelSpace, PaperSpace, PlotConfiguration, PlotConfigurations, RegisteredApplication, RegisteredApplications, SectionManager, SectionSettings, SortentsTable, TableStyle, TextStyle, TextStyles, UCS, UCSs, View, Views, Viewport, Viewports, XRecord
The objects this property applies to.
Read-only: Yes
Type: Long
The object ID of an object's owner.
No additional remarks.
VBA:
Sub Example_OwnerID32() ' This example creates an MText object in model space ' and then finds the OwnerID for the object. Dim MTextObj As AcadMText Dim corner(0 To 2) As Double Dim width As Double Dim text As String corner(0) = 0#: corner(1) = 10#: corner(2) = 0# width = 10 text = "This is the text string for the MText object" ' Creates the MText object Set MTextObj = ThisDrawing.ModelSpace.AddMText(corner, width, text) ZoomAll MsgBox "The OwnerID for the MText object is: " & MTextObj.OwnerID32 End Sub
Visual LISP:
(vl-load-com) (defun c:Example_OwnerID32() ;; This example creates an MText object in model space ;; and then finds the OwnerID for the object. (setq acadObj (vlax-get-acad-object)) (setq doc (vla-get-ActiveDocument acadObj)) (setq corner (vlax-3d-point 0 10 0) width 10 text "This is the text string for the MText object") ;; Creates the MText object (setq modelSpace (vla-get-ModelSpace doc)) (setq MTextObj (vla-AddMText modelSpace corner width text)) (vla-ZoomAll acadObj) (alert (strcat "The OwnerID for the MText object is: " (itoa (vla-get-OwnerID32 MTextObj)))) )