vlax-curve-isPeriodic (AutoLISP/ActiveX)

Determines if the specified curve has an infinite range in both directions and there is a period value dT, such that a point on the curve at (u + dT) = point on curve (u), for any parameter u

Supported Platforms: Windows only

Signature

(vlax-curve-isPeriodic curve-obj)
curve-obj

Type: VLA-object

The object to be tested.

Return Values

Type: T or nil

T if the curve is periodic; otherwise nil.

Examples

Determine if the ellipse used to demonstrate vlax-curve-getArea is periodic:

(vlax-curve-isPeriodic ellipseObj)
T

Determine if the spline used to demonstrate vlax-curve-getDistAtParam is periodic:

(vlax-curve-isPeriodic splineObj)
nil