vlax-curve-getArea (AutoLISP/ActiveX)

Returns the area inside the curve

Supported Platforms: Windows only

Signature

(vlax-curve-getArea curve-obj)
curve-obj

Type: VLA-object

The object to be measured.

Return Values

Type: Real or nil

A numeric value representing the area of the curve, if successful; otherwise nil.

Examples

Assume the curve being measured is the ellipse in the following drawing:

Sample curve (ellipse) for vlax-curve-getArea

The ellipseObj variable points to the ellipse VLA-object.

The following command obtains the area of the curve:

(vlax-curve-getArea ellipseObj)
4.712393