vlax-curve-isClosed (AutoLISP/ActiveX)

Determines if the specified curve is closed (that is, the start point is the same as the endpoint)

Supported Platforms: Windows only

Signature

(vlax-curve-isClosed curve-obj)
curve-obj

Type: VLA-object

The object to be tested.

Return Values

Type: T or nil

T if the curve is closed; otherwise nil.

Examples

Determine if the ellipse used to demonstrate vlax-curve-getArea is closed:

(vlax-curve-isClosed ellipseObj)
T

Determine if the spline used to demonstrate vlax-curve-getDistAtParam is closed:

(vlax-curve-isClosed splineObj)
nil