vlax-curve-isPlanar (AutoLISP/ActiveX)

Determines if there is a plane that contains the curve

Supported Platforms: Windows only

Signature

(vlax-curve-isPlanar curve-obj)
curve-obj

Type: VLA-object

The object to be tested.

Return Values

Type: T or nil

T if there is a plane that contains the curve; otherwise nil.

Examples

Determine if there is a plane containing the ellipse used to demonstrate vlax-curve-getArea:

(vlax-curve-isPlanar ellipseObj)
T

Determine if there is a plane containing the spline used to demonstrate vlax-curve-getDistAtParam:

(vlax-curve-isPeriodic splineObj)
nil