strcase (AutoLISP)

Returns a string where all alphabetic characters have been converted to uppercase or lowercase

Supported Platforms: Windows and Mac OS

Signature

(strcase string [which])
string

Type: String

The text string to convert.

which

Type: T or nil

If specified as T, all alphabetic characters in string are converted to lowercase. Otherwise, characters are converted to uppercase.

Return Values

Type: String

Converted text value.

Examples

(strcase "Sample")
"SAMPLE"

(strcase "Sample" T)
"sample"

The strcase function will correctly handle case mapping of the currently configured character set.