strlen (AutoLISP)

Returns an integer that is the number of characters in a string

Supported Platforms: Windows and Mac OS

Signature

(strlen [str ...])
str

Type: String

A textual value.

Return Values

Type: Integer

A numeric value. If multiple str arguments are provided, strlen returns the sum of the lengths of all arguments. If you omit the arguments or enter an empty string, strlen returns 0.

Examples

(strlen "abcd")
4

(strlen "ab")
2

(strlen "one" "two" "four")
10

(strlen)
0

(strlen "")
0