vl-string-left-trim (AutoLISP)

Removes the specified characters from the beginning of a string

Supported Platforms: Windows and Mac OS

Signature

(vl-string-left-trim character-set str)
character-set

Type: String

A textual value listing the characters to be removed.

str

Type: String

The textual value to be stripped of character-set.

Return Values

Type: String

A textual value containing a substring of str with all leading characters in character-set removed

Examples

(vl-string-left-trim " \t\n" "\n\t STR ")
"STR "

(vl-string-left-trim "12456789" "12463CPO is not R2D2")
"3CPO is not R2D2"

(vl-string-left-trim " " "     There are too many spaces here")
"There are too many spaces here"