vl-string-right-trim (AutoLISP)

Removes the specified characters from the end of a string

Supported Platforms: Windows and Mac OS

Signature

(vl-string-right-trim character-set str)
character-set

Type: String

A textual value listing the characters to be removed.

str

Type: String

The textual value to be stripped of character-set.

Return Values

Type: String

A textual value containing a substring of str with all trailing characters in character-set removed.

Examples

(vl-string-right-trim " \t\n" " STR \n\t ")
" STR"

(vl-string-right-trim "1356789" "3CPO is not R2D267891")
"3CPO is not R2D2"

(vl-string-right-trim " " "There are too many spaces here      ")
"There are too many spaces here"