vector_image (AutoLISP/DCL)

Draws a vector in the currently active dialog box image

Supported Platforms: Windows only

Signature

(vector_image x1 y1 x2 y2 color)
x1

Type: Integer

X coordinate of the first point.

y1

Type: Integer

Y coordinate of the first point.

x2

Type: Integer

X coordinate of the second point.

y2

Type: Integer

Y coordinate of the second point.

color

Type: Integer

An AutoCAD color number, or one of the logical color numbers shown in the following table:

Symbolic names for color attribute

Color number

ADI mnemonic

Description

-2

BGLCOLOR

Current background of the AutoCAD drawing area

-15

DBGLCOLOR

Current dialog box background color

-16

DFGLCOLOR

Current dialog box foreground color (text)

-18

LINELCOLOR

Current dialog box line color

Return Values

Type: Integer

A numeric value representing the color of the vector.

Remarks

This function draws a vector in the currently active dialog box image (opened by start_image) from the point (x1,y1) to (x2,y2). The origin (0,0) is the upper-left corner of the image. You can obtain the coordinates of the lower-right corner by calling the dimension functions (dimx_tile and dimy_tile).

Examples

(setq color -2) ;; color of AutoCAD drawing area
(vector_image
  0
  0
  (dimx_tile "slide_tile")
  (dimy_tile "slide_tile")
  color
)
(end_image)