vlax-curve-getFirstDeriv (AutoLISP/ActiveX)

Returns the first derivative (in WCS) of a curve at the specified location

Supported Platforms: Windows only

Signature

(vlax-curve-getFirstDeriv curve-obj param)
curve-obj

Type: VLA-object

The object to be measured.

param

Type: Integer or Real

A number specifying a parameter on the curve.

Return Values

Type: List or nil

A 3D vector, if successful; otherwise nil.

Examples

Obtain the start parameter of the curve:

(setq startSpline (vlax-curve-getStartParam splineObj))
0.0

Obtain the end parameter of the curve:

(setq endSpline (vlax-curve-getEndParam splineObj))
17.1546

Determine the first derivative at the parameter midway along the curve:

 (vlax-curve-getFirstDeriv splineObj
   ( / (- endspline startspline) 2))
(0.422631 -1.0951 0.0)