vlax-curve-getSecondDeriv (AutoLISP/ActiveX)

Returns the second derivative (in WCS) of a curve at the specified location

Supported Platforms: Windows only

Signature

(vlax-curve-getSecondDeriv curve-obj param)
curve-obj

Type: VLA-object

The object to be measured.

param

Type: Integer or Real

A number specifying a parameter on the curve.

Return Values

Type: List or nil

A 3D vector, if successful; otherwise nil.

Examples

For the following example, assume that splineObj points to the spline shown in the example of the vlax-curve-getDistAtParam function.

Obtain the start parameter of the curve:

(setq startSpline (vlax-curve-getStartParam splineObj))
0.0

Obtain the end parameter of the curve:

(setq endSpline (vlax-curve-getEndParam splineObj))
17.1546

Determine the second derivative at the parameter midway along the curve:

(vlax-curve-getSecondDeriv splineObj
   ( / (- endspline startspline) 2))
(0.0165967 0.150848 0.0)