vl-vbaload (AutoLISP)

Loads a VBA project

Supported Platforms: Windows only

Signature

(vl-vbaload filename)
filename

Type: String

Name of the VBA project file to be loaded.

Return Values

Type: String or error

A textual value containing the file name and path of the VBA project; otherwise an error occurs if the file is not found.

Important: Starting with AutoCAD 2014-based products, custom applications must work under secure mode; when the SECURELOAD system variable is set to 1 or 2. When operating under secure mode, the program is restricted to loading and executing files that contain code from trusted locations; trusted locations are specified by the TRUSTEDPATHS system variable.

Examples

(vl-vbaload "c:/program files/<AutoCAD installation directory>/sample/vba/drawline.dvb")
"c:\\program files\\<AutoCAD installation directory>\\sample\\vba\\drawline.dvb"