vlax-curve-getStartPoint (AutoLISP/ActiveX)

Returns the start point (in WCS) of the curve

Supported Platforms: Windows only

Signature

(vlax-curve-getStartPoint curve-obj)
curve-obj

Type: VLA-object

The object to be measured.

Return Values

Type: List or nil

A 3D point representing the start point, if successful; otherwise nil.

Examples

Get the start point of the ellipse.

(vlax-curve-getStartPoint ellipseObj)
(2.0 2.0 0.0)

For an ellipse, the start points and endpoints are the same.

Obtain the start point of the spline used to demonstrate vlax-curve-getDistAtParam:

(vlax-curve-getStartPoint splineObj)
(1.73962 2.12561 0.0)