BlockReference Object (ActiveX)

An instance of a block definition inserted into a drawing.

Supported Platforms: Windows only

Class Information

Class Name

AcadBlockReference

Object Inheritance
Object
   AcadObject
      AcadEntity
         AcadBlockReference
Create Using

VBA

ModelSpace.InsertBlock
PaperSpace.InsertBlock
Block.InsertBlock
Access Via

VBA

ModelSpace.Item
PaperSpace.Item
Block.Item
SelectionSet.Item
Group.Item

Members

These members are part of this object:

Remarks

To create a block reference, first you must create a block definition, or block, by using the Add method. Once created, you can insert an instance of this block into your drawing using the InsertBlock method.

To add or delete items from the block reference, you must first use the Explode method to break it into its component objects. Even though a block reference is broken into its component objects, the block definition still remains in the drawings block symbol table.