StyleName Property (ActiveX)

Specifies the name of the style used with the object.

Supported platforms: Windows only

Signature

VBA:

object.StyleName
object

Type: Attribute, AttributeReference, Dim3PointAngular, DimAligned, DimAngular, DimArcLength, DimDiametric, Dimension, DimOrdinate, DimRadial, DimRadialLarge, DimRotated, Leader, MLeader, MLine, MText, Table, Text, Tolerance

The objects this property applies to.

Property Value

Read-only: No; except MLine objects which are read-only

Type: String

The default equals the current style.

Remarks

Use the TextStyle object to change the attributes of a given text style. Use the DimStyle object to change the attributes of a given dimension style.

The name given must already be defined in the drawing.

Note: For dimensions, the value of this property is stored in the DIMSTYLE system variable.

Examples

VBA:

Sub Example_StyleName()
    ' This example creates an aligned dimension and then changes the
    ' StyleName property for that dimension.

    Dim dimObj As AcadDimAligned
    Dim point1(0 To 2) As Double
    Dim point2(0 To 2) As Double
    Dim location(0 To 2) As Double
    Dim currStyleName As String
    
    ' Define the dimension
    point1(0) = 5#: point1(1) = 3#: point1(2) = 0#
    point2(0) = 10#: point2(1) = 3#: point2(2) = 0#
    location(0) = 7.5: location(1) = 5#: location(2) = 0#

    ' Create an aligned dimension object in model space
    Set dimObj = ThisDrawing.ModelSpace.AddDimAligned(point1, point2, location)
    ZoomAll
    currStyleName = dimObj.styleName
    MsgBox "The initial StyleName for the dimension is " & dimObj.styleName, vbInformation, "TextString Example"
    
    ' Create a new dimension style
    ThisDrawing.DimStyles.Add ("NewDimensionStyle")
    
    ' Change the text string for the dimension
    dimObj.styleName = "NewDimensionStyle"
    dimObj.Update
    MsgBox "The new StyleName for the dimension is " & dimObj.styleName, vbInformation, "TextString Example"
    
    ' Reset the text string for the dimension
    dimObj.styleName = currStyleName
    dimObj.Update
    MsgBox "The StyleName for the dimension has been reset to " & dimObj.styleName, vbInformation, "TextString Example"
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_StyleName()
    ;; This example creates an aligned dimension and then changes the
    ;; StyleName property for that dimension.
    (setq acadObj (vlax-get-acad-object))
    (setq doc (vla-get-ActiveDocument acadObj))
    
    ;; Define the dimension
    (setq point1 (vlax-3d-point 5 3 0)
          point2 (vlax-3d-point 10 3 0)
          location (vlax-3d-point 7.5 5 0))

    ;; Create an aligned dimension object in model space
    (setq modelSpace (vla-get-ModelSpace doc))
    (setq dimObj (vla-AddDimAligned modelSpace point1 point2 location))
    (vla-ZoomAll acadObj)

    (setq currStyleName (vla-get-StyleName dimObj))
    (alert (strcat "The initial StyleName for the dimension is " currStyleName))
    
    ;; Create a new dimension style
    (vla-Add (vla-get-DimStyles doc) "NewDimensionStyle")
    
    ;; Change the text string for the dimension
    (vla-put-StyleName dimObj "NewDimensionStyle")
    (vla-Update dimObj)
    (alert (strcat "The new StyleName for the dimension is " (vla-get-StyleName dimObj)))
    
    ;; Reset the text string for the dimension
    (vla-put-StyleName dimObj currStyleName)
    (vla-Update dimObj)
    (alert (strcat "The StyleName for the dimension has been reset to " (vla-get-StyleName dimObj)))
)