vl-registry-read (AutoLISP)

Returns data stored by a specific key/value pair in the Windows Registry or property list file on Mac OS

Supported Platforms: Windows and Mac OS

Signature

(vl-registry-read reg-key [val-name])
reg-key

Type: String

Windows registry key or property list file key on Mac OS.

val-name

Type: String

Default value for the reg-key entry if it does not exist.

Return Values

Type: String or nil

A string containing the data stored in the key, if successful; otherwise nil.

Remarks

If val-name is supplied and is not nil, the specified value will be read from the registry or property list file. If val-name is absent or nil, the function reads the specified key and all of its values.

Examples

(vl-registry-read "HKEY_CURRENT_USER\\Test")
nil

(vl-registry-write "HKEY_CURRENT_USER\\Test" "" "test data")
"test data"

(vl-registry-read "HKEY_CURRENT_USER\\Test")
"test data"