vl-registry-delete (AutoLISP)

Deletes the specified key from the Windows Registry or property list file on Mac OS

Supported Platforms: Windows and Mac OS

Signature

(vl-registry-delete reg-key [val-name])
reg-key

Type: String

Windows registry key or property list file key on Mac OS.

val-name

Type: String

Value of the reg-key entry.

Return Values

Type: T or nil

T if successful; otherwise nil.

Remarks

If val-name is supplied and is not nil, the specified value will be purged from the registry or property list file. If val-name is absent or nil, the function deletes the specified key and all of its values.

Examples

(vl-registry-write "HKEY_CURRENT_USER\\Test" "" "test data")
"test data"

(vl-registry-read "HKEY_CURRENT_USER\\Test")
"test data"

(vl-registry-delete "HKEY_CURRENT_USER\\Test")
T
Note: This function cannot delete a key that has subkeys. To delete a subkey you must use vl-registry-descendents to enumerate all subkeys and delete all of them.