Windows Registry and property list (PLIST) file functions query and update the Windows Registry on Windows or property list files on Mac OS.
Windows Registry and Property List File functions |
|
---|---|
Function |
Description |
(vl-registry-delete reg-key [val-name]) |
Deletes the specified key from the Windows Registry or property list file on Mac OS |
(vl-registry-descendents reg-key [val-names]) |
Returns a list of subkeys or value names for the specified key of the Windows Registry or property list file on Mac OS |
(vl-registry-read reg-key [val-name]) |
Returns data stored by a specific key/value pair in the Windows Registry or property list file on Mac OS |
(vl-registry-write reg-key [val-name val-data]) |
Creates a key in the Windows Registry or property list file on Mac OS |
(vlax-machine-product-key) |
Returns the AutoCAD Windows Registry path in the HKLM (HKEY_LOCAL_MACHINE) Note: Available on Windows only and requires a call to the vl-load-com function.
|
(vlax-product-key) |
Returns the AutoCAD Windows Registry path (Obsolete) Note: Use the vlax-machine-product-key function instead.
|
(vlax-user-product-key) |
Returns the AutoCAD Windows registry path in the HKCU (HKEY_CURRENT_USER) Note: Available on Windows only and requires a call to the vl-load-com function.
|