vl-registry-descendents (AutoLISP)

Returns a list of subkeys or value names for the specified key of the Windows Registry or property list file on Mac OS

Supported Platforms: Windows and Mac OS

Signature

(vl-registry-descendents reg-key [val-names])
reg-key

Type: String

Windows registry key or property list file key on Mac OS.

val-names

Type: String

Values for the reg-key entry.

Return Values

Type: List or nil

A list of strings, if successful; otherwise nil.

Remarks

If val-names is supplied and is not nil, the specified value names will be listed from the registry. If val-name is absent or nil, the function displays all subkeys of reg-key.

Examples

(vl-registry-descendents "HKEY_LOCAL_MACHINE\\SOFTWARE")
("Description" "Program Groups" "ORACLE" "ODBC" "Netscape" "Microsoft")