vl-registry-write (AutoLISP)

Creates a key in the Windows Registry or property list file on Mac OS

Supported Platforms: Windows and Mac OS

Signature

(vl-registry-write reg-key [val-name val-data])
reg-key

Type: String

Windows registry key or property list file key on Mac OS.

Note: You cannot use vl-registry-write for HKEY_USERS or KEY_LOCAL_MACHINE.
val-name

Type: String

Value name for the key.

val-data

Type: String

Data for the value name.

Return Values

Type: String or nil

vl-registry-write returns val-data, if successful; otherwise nil.

Remarks

If val-name is not supplied or is nil, a default value for the key is written. If val-name is supplied and val-data is not specified, an empty string is stored.

Examples

(vl-registry-write "HKEY_CURRENT_USER\\Test" "" "test data")
"test data"

(vl-registry-read "HKEY_CURRENT_USER\\Test")
"test data"