GetPluginDescription Method (ActiveX/CSP)

Gets the descriptive strings of a plug-in.

For internal use only.

Supported platforms: Windows only

Namespace: AcStMgr

Assembly: AcStMgr.tlb

Signature

VB.NET:

object.GetPluginDescription(szProdID, szName, szVersion, szDescription, szAuthor, szHref, pHicon)

C#:

object.GetPluginDescription(szProdID, ref szName, ref szVersion, ref szDescription, ref szAuthor, ref szHref, ref pHicon);
object

Type: AcStManager object

The object this method applies to.

szProdID

Access: Input-only

Type: String

The ProgId of the plug-in to get information about.

szName

Access: Input/Output

Type: String

The name assigned to the plug-in.

szVersion

Access: Input/Output

Type: String

the version of the plug-in.

szDescription

Access: Input/Output

Type: String

The description of the plug-in.

szAuthor

Access: Input/Output

Type: String

The name of the company or individual who wrote the plug-in.

szHref

Access: Input/Output

Type: String

The Uniform Resource Locator (URL) assigned to the plug-in.

pHicon

Access: Input/Output

Type: LongPtr (Long)

The pointer to the icon (HICON) assigned to the plug-in.

Return Value (RetVal)

No return value.

Remarks

The pointer to the icon is temporary, applications that intend to use the icon should make a persistent copy.

Release Information

Releases: AutoCAD 2004 and later

Examples

VB.NET:

Not available

C#:

Not available