About Using the Transmittal Object Library (ActiveX/ATO)

After a reference to the Transmittal Object library has been added to a project, make sure to import the TRANSMITTALLib namespace or include the appropriate header file based on the programming language being used to develop the application. The Transmittal Object library is stored in the acETransmit<version>.tlb, see "About Getting Started with the Transmittal Object Library" for information on accessing the Transmittal Object library and other related libraries.

If you are using a .NET programming language, import the TRANSMITTALLib namespace into the class or code modules that need access to the Transmittal Object library. For example:

VB.NET
Imports TRANSMITTALLib
C#
using TRANSMITTALLib;

If you are using the C++ programming language, make sure to include the Transmittal.h file in the code modules that need to access the Transmittal Object library. For example:

#include "Transmittal.h"

After the Transmittal Object library has been imported or included as part of a module, you use the ITransmittalOperation and ITransmittalInfo interfaces to create a transmittal set or add files to a transmittal set. The ITransmittalFile interface describes a file referenced in a transmittal set.

While working with a transmittal set, you can register event handlers that allow the Transmittal engine to communicate with a custom program. The ITransmittalDatabaseNotificationHandler and ITransmittalAddFileNotificationHandler interfaces provide notifications to third-party applications whenever a transmittal set is created or a file is added to a transmittal set, respectively. Additionally, you can use the ITransmittalSheetSetNotification to monitor files being added to a transmittal set from a sheet set and the ITransmittalProgressHandler interface to monitor the progress of specific operations when they are being performed on a transmittal set.