vl-symbol-value (AutoLISP)

Returns the current value bound to a symbol

Supported Platforms: Windows and Mac OS

Signature

(vl-symbol-value symbol)
symbol

Type: Symbol

Any LISP symbol.

Return Values

Type: Integer, Real, String, List, File, Ename (entity name), T, or nil

The value of symbol, after evaluation.

Remarks

This function is equivalent to the eval function, but does not call the LISP evaluator.

Examples

(vl-symbol-value 't)
T

(vl-symbol-value 'PI)
3.14159

(progn (setq sym 'PAUSE) (vl-symbol-value sym))
"\\"