vl-symbol-name (AutoLISP)

Returns a string containing the name of a symbol

Supported Platforms: Windows and Mac OS

Signature

(vl-symbol-name symbol)
symbol

Type: Symbol

Any LISP symbol.

Return Values

Type: String or error

A string containing the name of the supplied symbol argument, in uppercase.

Examples

(vl-symbol-name 'S::STARTUP)
"S::STARTUP"

(progn (setq sym 'my-var) (vl-symbol-name sym))
"MY-VAR"

(vl-symbol-name 1)
; *** ERROR: bad argument type: symbolp 1