vl-symbolp (AutoLISP)

Identifies whether or not a specified object is a symbol

Supported Platforms: Windows and Mac OS

Signature

(vl-symbolp object)
object

Type: Integer, Real, String, List, File, Symbol, Ename (entity name), T, or nil

Any LISP object.

Return Values

Type: T or nil

T if object is a symbol; otherwise nil.

Examples

(vl-symbolp t)
T

(vl-symbolp nil)
nil

(vl-symbolp 1)
nil

(vl-symbolp (list 1))
nil