“编辑 UVW”对话框菜单栏

通过“编辑 UVW”对话框菜单栏可以使用许多重要的编辑命令。这些命令中的一些也在对话框工具栏和“展开 UVW”命令面板上;其他命令,例如“贴图”、“缝合”和“草图”工具,只在菜单上。

提示: 默认情况下,一些命令在编辑器界面中不可用,您可以使用“自定义用户界面”对话框来添加它们。

界面

“文件”菜单

加载 UV

加载以前保存的 UVW(纹理坐标)文件。

保存 UV

将 UVW 坐标保存为 UVW 文件。

全部重置

将 UVW 坐标还原为其原始状态。

除了没有删除“编辑 UVW”对话框中指定的贴图之外,“重置全部”几乎与移除并重新应用修改器有相同的效果。例如,如果忘记了启用对象的“生成贴图坐标”复选框,然后应用了“UVW 展开”修改器,那么修改器将没有 UVW 坐标可用,并且其设置会发生错误。如果此时返回到修改器堆栈并启用“生成贴图坐标”,则需要选择“重置所有”命令。如此操作完后,出现警告正在丢失所做过的任何编辑的警报。

“编辑”菜单

通过这些命令可以使用不同的变换功能、复制和粘贴选择。

复制

将当前选择(即纹理坐标)复制到粘贴缓冲区。

粘贴

将粘贴缓冲区中的纹理贴图坐标应用于当前选择。对同一目标坐标重复使用“粘贴”会导致坐标每次旋转 90 度。

使用“复制”和“粘贴”可以将同一贴图坐标(即图形)应用于许多不同的几何体多边形。一个典型的应用例子就是在设计游戏层级时,会使用多个图形纹理贴图,部分贴图是一个门的图像。有时想将同一个门的图像应用到几个不同的门多边形。首先,选择一个门多边形并将它定位到门图像上。接下来,使用“复制”可以将它的纹理坐标放置到粘贴缓冲区。然后选择另一个门多边形并选择“粘贴”或者“粘贴焊接”。门的纹理坐标将移动到原始多边形的位置。继续选择其他门多边形并粘贴,直到对所有的门做完贴图为止。

提示: 为了获得最佳结果,对源和目标使用类似的纹理坐标组。例如,复制单个四边形,然后粘贴另一个四边形。
粘贴焊接

将粘贴缓冲区中的内容应用于当前选择,然后合并重合顶点,会有效地将源和目标选择熔合在一起。

使用此功能可以得到应用于多个几何体元素的单个纹理坐标组。调整这些纹理坐标可以更改应用于所有几何体的贴图。

移动模式

用于选择和移动子对象。

旋转模式

用于选择和旋转子对象。

缩放模式

用于选择和缩放子对象。

自由形式 Gizmo

用于选择和变换顶点。请参见自由形式模式。

“选择”菜单

这些命令可以将视口选择复制到编辑器,并在三个不同的子对象模式之间传输选择。

将顶点转化为边

将当前顶点选择转化为边选择并进入“边”子对象模式。如果只选定一个边,它的两个顶点必须都被选定。

将顶点转化为多边形

将当前顶点选择转化为多边形选择并进入“多边形”子对象模式。如果只选定一个多边形,它的所有顶点必须都被选定。

将边转化为顶点

将当前边选择转化为顶点选择并进入“顶点”子对象模式。

将边转化为多边形

将当前边选择转化为多边形选择并进入“多边形”子对象模式。如果只选定一个多边形,当前边选择必须包括它的所有顶点。例如,如果选定四边形中的两个相对边,边选择包括所有四个面的顶点,因此该命令将选择此多边形。

将多边形转化为顶点

将当前多边形选择转化为顶点选择并进入“顶点”子对象模式。

将多边形转化为边

将当前多边形选择转化为边选择并进入“边”子对象模式。

选择反转多边形
选择任何背离当前贴图方向的多边形。只在多边形选择模式可用。

复杂模型中,在折叠自身的曲面上寻找多边形将导致潜在的使用凹凸贴图困难,此时该功能很有用。

例如,添加球体,禁用“生成贴图坐标”,然后应用“UVW 展开”。这将导致修改器从上到下应用平面贴图,因此将反转球体下半部的所有多边形;也就是说,它们面向背离贴图的方向。在修改器堆栈显示中,高亮显示“选择多边形”子对象层级,然后单击“编辑”按钮可以打开 UVW 编辑器。选择“多边形”选择模式,然后选择“选择”“选择反转多边形”。在视口中,球体的下半部变为红色,指示反转多边形现在已选定。

选择重叠多边形
选择任意与其他多边形重叠的多边形。如果没有选定多边形,则该选项选择所有重叠的多边形。如果存在多边形选择,则该选项只选择选择之内的重叠多边形。只在多边形选择模式可用。

使用复杂网格时,纹理坐标多边形通常覆盖在另一个多边形上,结果是它们使用纹理贴图的相同部分。使用该命令查找重叠的多边形,以便按照需要分隔它们。

“工具”菜单

该菜单上的工具用来翻转和镜像纹理坐标、焊接顶点、合并和分离纹理坐标组,并为多个选定顶点做轮廓草图。

水平/垂直翻转

沿边界分离选定子对象,然后应用“水平镜像”或者“垂直镜像”,应用哪种镜像取决于模式。

水平/垂直镜像

沿所指示的轴反转选定子对象的方向并相应地翻转 UV。

焊接选定项
合并属于由“焊接阈值”设置指定的 UV 空间半径内的选定子对象的共享顶点和边。使用此选项可以连接单独的纹理坐标群集。
目标焊接

通过拖动方式合并成对的顶点或边。该功能在“多边形”子对象层级不可用。

启用目标焊接,然后拖动一个顶点到另一个顶点,或者一个边到另一个边。拖动时,光标在有效子对象上时变为十字线。该命令处于激活状态时,可以继续焊接子对象和更改子对象层级。要退出目标焊接模式,请在编辑器窗口中右键单击。

断开

应用于当前选择;在三个子对象模式中有不同作用。在“顶点”子对象层级,使用“打破”将每一个共享顶点替换为两个顶点。对于边,“打破”要求至少选定两个连续边,并将每个边分成两个。对于多边形,“打破”将对网格剩余部分的选定分割成新元素,就像“分离边顶点”做的一样。

分离边顶点

尝试将当前选择分割成新元素。在分离前,从选定组中移除任何无效顶点或者边。

缝合选定项

对当前选定项,找到所有指定给同一几何体顶点的纹理顶点,将它们都移动到同一点,然后将它们焊接在一起。使用此工具可以自动地连接在对象网格中,却不在编辑器中的连续多边形。

要使用“缝合选定项”,首先沿想要连接(默认情况,这将导致共享边高亮显示)的边选择子对象,然后选择命令。在“缝合工具”对话框中,调整设置,单击“确定”以接受设置,或单击“取消”以放弃设置。

紧缩 UV

使用两种方法之一和指定的间隔,在纹理空间分布所有纹理坐标簇。如果有几个重叠簇并且想分离它们时,该命令很有用。

选择紧缩 UV 可以打开“紧缩”对话框。

重缩放群集
按相对比例原地自动缩放群集。仅适用于每个群集中至少选定一个子对象的两个或多个群集。如果未选择任何子对象,将应用于所有群集。
草图顶点

使用鼠标画出顶点选择的轮廓。将坐标簇轮廓匹配到纹理贴图 en masse 的节中而不想每次移动一个顶点时,该命令很有用。

选择“草图顶点”可以打开“草图工具”对话框。“草图顶点”仅在“顶点”子对象模式中可用。

“松弛”对话框

打开非模式“松弛工具”对话框,该对话框允许您通过移动顶点接近或者远离它们的相邻顶点,更改选定纹理顶点中明显的曲面张力。松弛纹理顶点可以使其距离更均匀,从而更容易进行纹理贴图。在子对象层级可用。

注: 该命令和用来应用默认设置到当前选定而不打开对话框的“松弛”命令,有指定的键盘快捷方式可用。
渲染 UVW 模板

打开“渲染 UV”对话框,该对话框允许您将纹理贴图数据导出为一个图像文件,之后您可以将该文件导入到 2D 绘图软件中。

“贴图”菜单

用于将三种不同类型的自动和程序贴图方法中的一种应用于模型。通过每一个方法提供的设置可以调整正在使用的几何体的贴图。

注: 这些贴图工具仅在多边形选择模式下适用,在“顶点”和“边”子对象层级不可用。

每一种方法都将贴图应用到当前多边形选择;如果没有多边形选择,将应用到整个网格。

下面是可用方法的概述:

  • 展平贴图可避免贴图簇的重叠,但是仍会导致纹理扭曲。
  • 法线贴图是最简单的方法,但是会导致比“压平”贴图更严重的纹理扭曲。
  • “展开”贴图消除了纹理扭曲,但是会导致重叠坐标簇。
提示: 在许多情况下,自动贴图功能中的一种会提供有用的结果。但是对某些自定义或者复杂对象,用手动贴图可能会获得最佳的结果;使用有变化的基本步骤,或者对自定义贴图使用程序性方法作为入门方法。
展平贴图

将平面贴图应用于落入指定角度阈值中的连续多边形组。

选择“展平贴图”可以打开“展平贴图”对话框。

法线贴图

基于不同矢量投影方法,应用平面贴图。

选择“法线贴图”可以打开“法线贴图”对话框。

展开贴图

展开网格以便消除多边形扭曲,但是不能保证多边形不会重叠。

选择“展开贴图”可以打开“展开贴图”对话框。

“选项”菜单

加载默认值

从 plugcfg 目录中的文件 unwrapuvw.ini ,加载编辑器设置。

保存当前设置为默认值

将编辑器设置保存到 plugcfg 目录中的文件 unwrapuvw.ini 中。按此方法保存的设置在会话间持续存在。

始终显示编辑窗口

启用此选项后,且“展开 UVW”修改器处于激活状态下时,选择对象将自动打开“编辑 UVW”对话框。默认情况下,该命令是禁用的,因此必须单击“参数”卷展栏 “编辑”按钮以打开对话框。

首选项

打开“展开选项”对话框。

“显示”菜单

隐藏选择

隐藏所有选定子对象以及关联多边形。

全部取消隐藏

显示任意隐藏的子对象。

全部解冻

将所有冻结的子对象解冻。

注: 您可以使用“冻结选定对象”来冻结子对象选择,可通过右键单击菜单 “显示”四元菜单执行此操作。
过滤选定面

启用此选项后,编辑器显示修改器的“多边形”子对象层级中视口选择的 UVW 顶点,并隐藏其他顶点。

这是忽略其余顶点的情况下,使用复杂网格有限选择的纹理坐标的快捷方法。您可以启用该选项,转到“展开 UVW”修改器的“多边形”子对象层级,并且选择要编辑其纹理坐标的对象部分;编辑器中将只出现这些坐标,甚至在更改子对象层级时仍然可见。若要使用不同的部分,请返回“多边形”层级并更改视口中的选择;编辑器窗口自动更新为新的选择。

显示隐藏边

切换隐藏多边形边的显示。

显示边扭曲

使用由绿到红的颜色范围来描述扭曲:纹理边在长度上与它们相应的几何体有大差别。长度的差别越大(也就是说扭曲越大),“编辑 UVW”对话框窗口中出现的边越红。也可以将太长的边结尾部分绘制为白色,显示距离几何体边的长度差别。

左:与几何体边长度相同或非常相近的纹理边为绿色。

中:与几何体边长度稍微不同的纹理边为棕色。

右:与几何体边长度有很大不同的纹理边为红色。

当纹理边比几何体边长时,白色结尾部分表示长度的不同。

使用该显示作为一种在纹理网格中最大扭曲区域的位置。如果一个边为棕色或红色,但是没有白色的结尾部分,则它太短了。如果为棕色或红色,并且具有白色的结尾部分,则按照白色部分的总长度,该边太长了。

显示顶点连接

在“顶点”子对象模式中,对所有选定顶点切换数字标签的显示。共享顶点显示为多个同样数值标签。

显示共享子对象

启用该选项后,对当前选择,高亮显示任何共享顶点和/或边。可以在“展开选项”对话框中更改高亮显示的颜色。

视图菜单

平移

激活“平移”工具,可使用该工具通过拖动鼠标在窗口中水平和垂直移动。

与视口一样,如果您使用的是三键鼠标,则还可以通过中键拖动来进行平移。

缩放

选择“缩放”,然后在编辑器窗口中向下拖动可缩小,向上拖动可放大。缩放以您拖动之前单击的点为中心居中。

如果鼠标有滚轮,也可以转动滚轮进行缩放。缩放以鼠标光标位置为中心。

缩放区域

要缩放特定区域,请选择“缩放区域”,然后拖动编辑器窗口中的方框。

最大化显示

自动缩小或者放大以适配编辑器窗口中的所有 UVW 顶点。

最大化显示选定对象

自动缩小或者放大以适配编辑器窗口中所有选定的 UVW 顶点。

缩放到 Gizmo

将活动视口缩放到当前选择。

显示栅格

在编辑器窗口的背景中显示栅格。默认设置为启用。

显示贴图

在编辑器窗口的背景中显示纹理贴图。通过编辑器工具栏右端的下拉列表设置该图像。

更新贴图

使显示的纹理贴图反映出对纹理的任何更改,如平铺设置和不同的位图。