These ActiveX methods all start with 'G'.
Generates the layout of a table.
Generates 2D or 3D section geometry.
Generates data specifying whether a layer is in use.
Gets an AcadState object to monitor the state of AutoCAD from out-of-process applications.
Returns the cell alignment for a row type.
Gets the cell alignment.
Gets all available profiles for the system.
Gets the angle specified. Considers the setting of the ANGBASE system variable.
Returns the attachment point for the specified row and column.
Gets the attributes in the block reference.
Returns the value specifying whether auto scale is used in the specified row and column.
Gets the auto scale flag value for a cell.
Returns the background color value for the specified row type.
Returns the background color value for the specified cell style.
Returns the value specifying that there is no background color for the specified row type.
Gets the large and small bitmaps used as icons for the toolbar item.
Gets the attribute value in the block content with an attribute definition id.
Gets the attribute value associated to a specified block cell.
For a 64-Bit system, gets the attribute value associated to a specified block cell. (Obsolete)
For a 64-Bit system, gets the attribute value in block content with attribute definition id. (Obsolete)
Returns the block rotation angle for the specified row and column.
Returns the block scale value for the specified row and column.
Returns the block table record ID of the cell.
Gets the block table record object id associated to a specified cell.
For a 64-Bit system, gets the block table record object id associated to a specified cell. (Obsolete)
For a 64-Bit system, gets a cell's block table record id. (Obsolete)
Gets two points of a box enclosing the specified object.
Get the break height of the table.
Gets the bulge value at a given index of the polyline.
Gets all available canonical media names for the specified plot device.
Returns the alignment for the cell in the specified row and column.
Returns the background true color value of a cell in the specified row and column.
Returns the value specifying that there is no background color for the specified row and column.
Gets the class of a cell style.
Returns the true color value for the content of the specified row and column.
Gets the true color value for a cell.
Gets the cell data and unit type for the given row and column.
Returns the cell extents for the specified row and column.
Gets the cell format for the given row and column.
Returns the grid color value for an edge of the specified row and column.
Returns the grid lineweight value for an edge of the specified row and column.
Returns the grid visibility value for an edge of the specified row and column.
Get a cell's state.
Gets the cell style.
Returns the cell style overrides.
Gets an array of all the named cell styles associated with the table style.
Returns the text height for the specified row and column.
Returns the text style name for the specified row and column.
Returns the cell type for the specified row and column.
Gets the cell value for the given row and column.
Returns the true color value for the specified row type.
Returns the color value for the specified named cell style.
Gets a column's name.
Returns the column width for the column at the specified column index in the table.
Gets the constant attributes in the block or external reference.
Returns the true color value for the specified row type.
Returns the color value for the specified content located at the provided row, column, and content index.
Get a cell's content layout.
Get a cell's content type.
Gets the coordinates of the control point at a given index.
Gets a corner of a rectangle.
Returns the custom property name (key) and value that correspond to an index value.
Returns the custom property value that corresponds to a name (key) value.
Gets the custom data associated to a cell.
Gets the custom scale for a layout or plot configuration.
Gets a cell's format.
Returns the data type and unit type for the specified row type.
Gets the row data type and unit type for the specified row type and nContent.
Gets the distance from the prompt line or a selected set of points on the screen.
Gets the dog leg direction of the specific leader.
Gets the properties of the dynamic block.
Gets an object interactively.
Gets the extension dictionary associated with an object.
Returns the field object ID of the specified cell.
Gets the field object id associated to the specified cell.
For a 64-Bit system, gets a cell's field object id. (Obsolete)
For a 64-Bit system, gets the field object ID of the specified cell. (Obsolete)
Gets the fit point of a spline at a given index.
Gets the definition data of the font for the TextStyle.
Returns the format for the specified row type.
Gets the format of a cell style.
Get a cell's formula.
Returns all of the objects in a block, sorted by draw order with the bottom object first.
Returns the grid color value for a grid linetype and row type.
Gets the gridColor for the specified cell.
Gets the lineSpacing value for the specified cell.
Get a cell's gridLineStyle.
Gets the idLinetype with the gridLinetype value for the specified cell.
For a 64-Bit system, gets the idLinetype with the gridLinetype value for the specified cell. (Obsolete)
Returns a grid lineweight value for a grid linetype and row type.
Gets the gridLineWeight value for the specified cell.
Gets the grid spacing for the viewport.
Returns a grid visibility value for the specified grid linetype and row type.
Returns the gridVisibility value for the specified cell.
Check if a cell has a formula.
Converts a user's input string into a keyword index.
Gets an integer value from the user.
Accepts a program ID and attempts to load it into AutoCAD as an in-process server.
Gets the visibility setting for an edge of a 3DFace object at a given index.
Gets the usage status of a cell style.
Gets value of the "merge all" property.
Gets a keyword string from the user.
Gets the index of leader cluster which the specified leader line is in.
Gets the indexes of leaderlines of the specific leader.
Gets the vertices of leaderLine with specified index.
Gets the live section plane that is currently enabled in the database.
Gets the localized version of the canonical media name.
Gets the hatch loop at a given index.
Get a cell's margin value.
Gets the minimum column width for the column at the specified column index in the table.
Returns the minimum row height for the specified row.
Gets the name (keyword) of an object in a dictionary.
Gets the object in a dictionary, given the name (keyword) of the object.
Returns an object's ID as a string.
Gets the angle specified. Ignores the setting of the ANGBASE system variable.
Get a cell's overrides.
Gets the margins for the layout or plot configuration.
Gets the width and height of the configured paper.
Gets all available plot device names.
Gets all available plot style table names.
Gets the point selected in AutoCAD.
Gets the directory in which AutoCAD looks for external reference files.
Gets a real (double) value from the user.
Returns the objects specified, sorted by the draw order, with the bottom object first.
Downloads the file specified by a URL.
Gets the rotation value for a cell or cell style.
Returns the row height for the row at the specified row index in the table.
Returns the row type for the specified row.
Gets the scale value for a cell.
Gets the section type settings object.
Gets the snap spacing for the viewport.
Gets a string from the user.
Gets an object or subentity interactively.
For a 64-Bit system, gets an object or subentity interactively. (Obsolete)
Returns the row and column indexes of the cells in a subselection set.
Returns the text value for the specified row and column.
Returns the text height for the specified row type.
Gets the text height for a cell.
Returns the text rotation for the specified row and column.
Gets the text value of a cell.
Gets the text style name for the specified row types.
Gets the text style name for a cell.
Gets the object id for a named cell style.
For a 64-Bit system, gets the object id for a named cell style. (Obsolete)
Gets the transformation matrix consisting of UCS coordinate system data.
Gets a unique cell style name with the base name that is passed as the prefix.
Finds a unique section plane name.
Gets the value of a cell.
Gets the current setting of an AutoCAD system variable.
Gets the number of vertices in the specified leaderline.
Gets the weight of the control point at a given index.
Gets the start and end width for a polyline.
Gets the coordinates that define the portion of the layout to plot.
Gets the extended data (XData) associated with an object.
Gets the extended record data (XRecordData) associated with a dictionary.