Share

AnchorLocationType Enumeration

Enumerates where to anchor various label annotations.



Namespace: Autodesk.Civil
Assembly: AeccDbMgd (in AeccDbMgd.dll) Version: 13.7.0.765

Syntax

C#

public enum AnchorLocationType

VB

Public Enumeration AnchorLocationType

C++

public enum class AnchorLocationType

Members

Member nameValueDescription
Start134,263,041 
Middle134,263,042 
End134,263,043 
TopLeft134,263,044 
TopCenter134,263,045 
TopRight134,263,046 
MiddleLeft134,263,047 
MiddleCenter134,263,048 
MiddleRight134,263,049 
BottomLeft134,263,050 
BottomCenter134,263,051 
BottomRight134,263,052 
InsertionPoint134,263,053 
Station134,263,072 
LabelLocation134,263,073 
PI134,263,074 
PVI134,263,088 
CurveStart134,263,089 
CurveEnd134,263,090 
PVIExtension134,263,091 
CurveStartExtension134,263,092 
CurveMiddleExtension134,263,093 
CurveEndExtension134,263,094 
CurveHighPoint134,263,095 
CurveLowPoint134,263,096 
TangentStart134,263,097 
TangentMiddle134,263,098 
TangentEnd134,263,099 
TangentStartExtension134,263,100 
TangentMiddleExtension134,263,101 
TangentEndExtension134,263,102 
StationExtension134,263,103 
BandTop134,263,104 
BandMiddle134,263,105 
BandBottom134,263,106 
StartExtension134,263,107 
MiddleExtension134,263,108 
EndExtension134,263,109 
Offset134,263,152 
GradeBreak134,263,154 
GradeBreakExtension134,263,155 

Remarks

Used in BlockLabelStyles, VectorArrowLabelStyles, LineLabelStyles, and TextLabelStyles. There are nine anchor point values representing points along a rectangle that encompasses the entire text component and are relative to the rotation angle of the text.

See Also

Reference

Was this information helpful?