Share

GeometryPointLabelOption<T> Class

This class controls the selection state of a point type. The class is implemented as a generic that can be parameterized on the point type to manage.

Inheritance Hierarchy

SystemObject
  Autodesk.CivilGeometryPointLabelOptionT


Namespace: Autodesk.Civil
Assembly: AeccDbMgd (in AeccDbMgd.dll) Version: 13.7.0.765

Syntax

C#

public class GeometryPointLabelOption<T>
where T : Enum

VB

Public Class GeometryPointLabelOption(Of T As Enum)

C++

generic<typename T>
where T : Enum
public ref class GeometryPointLabelOption

Type Parameters

T

The GeometryPointLabelOptionT type exposes the following members.

Constructors

 NameDescription
Public methodGeometryPointLabelOptionTInitializes a new instance of the GeometryPointLabelOptionT class

Properties

 NameDescription
Public propertyPointType 
Public propertySelected 

See Also

Reference

Was this information helpful?