This class hanle the exception for any operation on the surface.
Inheritance Hierarchy
SystemObjectSystemException
Autodesk.CivilCivilException
Autodesk.CivilSurfaceException
Namespace: Autodesk.Civil
Assembly: AeccDbMgd (in AeccDbMgd.dll) Version: 13.7.0.765
Syntax
C#
[SerializableAttribute] public class SurfaceException : CivilException
VB
<SerializableAttribute> Public Class SurfaceException Inherits CivilException
C++
[SerializableAttribute] public ref class SurfaceException : public CivilException
The SurfaceException type exposes the following members.
Constructors
Name | Description | |
---|---|---|
![]() | SurfaceException | Initializes a new instance of the SurfaceException class |
![]() | SurfaceException(String) | Initializes a new instance of the SurfaceException class |
![]() | SurfaceException(SurfaceStatus) | Initializes a new instance of the SurfaceException class |
![]() | SurfaceException(String, Exception) | Initializes a new instance of the SurfaceException class |
![]() | SurfaceException(SurfaceStatus, String) | Initializes a new instance of the SurfaceException class |