These AutoLISP functions all start with 'V'.
Draws a vector in the currently active dialog box image
Returns a string that contains the current AutoLISP version number
Defines an AutoLISP function symbol as an external subroutine
Undefines an AutoLISP function symbol so it is no longer available to ObjectARX applications
Imports ObjectARX/ADSRX functions into a separate-namespace VLX
Returns the value of a variable from the blackboard namespace
Sets a variable in the blackboard namespace
Passes a list of arguments to a specified function and traps any exceptions
Returns a string from an error object
Determines whether an argument is an error object returned from vl-catch-all-apply
Executes an AutoCAD command
Determines whether or not a list is nil
Lists all files in a given directory
Makes a function available to the current document
Imports a previously exported function into a VLX namespace
Retrieves the value of a variable from the current document's namespace
Sets the value of a variable in the current document's namespace
Checks whether the predicate is true for every element combination
Passes control from an error handler to the *error* function of the calling namespace
Returns a value to the function that invoked the *error* handler from another namespace
Copies or appends the contents of one file to another file
Deletes a file
Determines if a file name refers to a directory
Renames a file
Determines the size of a file, in bytes
Returns last modification time of the specified file
Returns the name of a file, after stripping out the directory path and extension
Returns the directory path of a file, after stripping out the name and extension
Returns the extension from a file name, after stripping out the rest of the name
Calculates a unique file name to be used for a temporary file
Returns the text stored in a .txt file packaged in a VLX
Constructs and returns a list
Combines the characters associated with a list of integers into a string
Lists exported functions
Calculates list length of a true list
Returns a list of all separate-namespace VLX files associated with the current document
Loads a file into all open AutoCAD documents, and into any document subsequently opened during the current AutoCAD session
Loads the extended AutoLISP functions related to ActiveX support
Loads reactor support functions
Determines if the predicate is nil for one of the list members
Determines if the predicate is true for one of the list members
Creates a directory
Returns the index of the specified list item
Returns the string representation of LISP data as if it were output by the prin1 function
Returns the string representation of LISP data as if it were output by the princ function
Copies the value of a variable into all open document namespaces (and sets its value in any subsequent drawings opened during the current AutoCAD session)
Deletes the specified key or value from the Windows registry or property list file on Mac OS
Returns a list of subkeys or value names for the specified Windows registry key or property list file key on Mac OS
Returns data stored in the Windows registry or property list file key on Mac OS for the specified key/value pair
Creates a key in the Windows registry or property list file on Mac OS
Returns all elements of the supplied list that pass the test function
Returns all elements of the supplied list that fail the test function
Removes elements from a list
Checks whether the predicate is not nil for one element combination
Sorts the elements in a list according to a given compare function, and returns the element index numbers
Sorts the elements in a list according to a given compare function
Converts a string into a list of character codes
Returns the ASCII representation of the character at a specified position in a string
Removes the specified characters from the beginning of a string
Returns the length of the longest common prefix for two strings, starting at specified positions
Looks for a character with the specified ASCII code in a string
Removes the specified characters from the end of a string
Searches for the specified pattern in a string
Substitutes one string for another, within a string
Replaces characters in a string with a specified set of characters
Removes the specified characters from the beginning and end of a string
Returns a string containing the name of a symbol
Returns the current value bound to a symbol
Identifies whether or not a specified object is a symbol
Unload a VLX application that is loaded in its own namespace
Loads a VBA project
Runs a VBA macro
Determines whether a separate-namespace VLX is currently loaded
Creates ActiveX-compatible (variant) 3D point structure
Adds commands to the AutoCAD built-in command set
Creates a new instance of an application object
Returns the area inside the curve
Returns the point (in WCS) on a curve that is nearest to the specified point
Returns the closest point (in WCS) on a curve after projecting the curve onto a plane
Returns the length of the curve's segment from the curve's beginning to the specified parameter
Returns the length of the curve's segment between the curve's start point and the specified point
Returns the parameter of the endpoint of the curve
Returns the endpoint (in WCS) of the curve
Returns the first derivative (in WCS) of a curve at the specified location
Returns the parameter of a curve at the specified distance from the beginning of the curve
Returns the parameter of the curve at the point
Returns the point (in WCS) along a curve at the distance specified by the user
Returns the point at the specified parameter value along a curve
Returns the second derivative (in WCS) of a curve at the specified location
Returns the start parameter on the curve
Returns the start point (in WCS) of the curve
Determines if the specified curve is closed (that is, the start point is the same as the endpoint)
Determines if the specified curve has an infinite range in both directions and there is a period value dT, such that a point on the curve at (u + dT) = point on curve (u), for any parameter u
Determines if there is a plane that contains the curve
Lists an object's properties, and optionally, the methods that apply to the object
Transforms an entity to a VLA-object
Determines whether an object was erased
Iterates through a collection of objects, evaluating each expression
Retrieves the top level AutoCAD application object for the current AutoCAD session
Returns a running instance of an application object
Returns a running instance of an application object, or creates a new instance if the application is not currently running
Retrieves a VLA-object's property
Imports information from a type library
Calls the specified ActiveX method
Erases LISP data from a drawing dictionary
Retrieves LISP data from a drawing dictionary or an object
Lists AutoLISP data in a drawing dictionary
Stores LISP data in a drawing dictionary or an object
Determines if data can be saved over a session boundary
Returns the AutoCAD Windows registry path in the HKLM (HKEY_LOCAL_MACHINE)
Creates a safearray
Creates a variant data type
Applies a function to all objects in a collection
Determines if an object supports a particular method
Determines if an object has been released
Returns the AutoCAD Windows registry path
Determines if an object has a specified property
Sets the property of an ActiveX object
Determines if an object can be read
Releases a drawing object
Removes a single command or a command group
Returns the elements of a safearray in list form
Stores data in the elements of a safearray
Returns the number of dimensions in a safearray object
Returns an element from an array
Returns the lower boundary (starting index) of a dimension of an array
Returns the upper boundary (end index) of a dimension of an array
Adds an element to an array
Returns the data type of a safearray
Returns a suitable representation for a 4 x 4 transformation matrix to be used in VLA methods
Determines whether TypeLib information is present for the specified type of object
Returns the AutoCAD Windows registry path in the HKCU (HKEY_CURRENT_USER)
Returns the value of a variant after changing it from one data type to another
Determines the data type of a variant
Returns the value of a variant
Transforms a VLA-object to an AutoLISP entity
Determines if an AutoCAD drawing object can be modified
Compiles AutoLISP source code into a FAS file
Constructs a reactor object that notifies when an object is added to, modified in, or erased from a drawing database
Enables a disabled reactor object
Tests to determine if a reactor object is enabled
Produces a beep sound
Constructs an editor reactor that notifies of a command event
Returns the name (symbol) of the current event, if called from within a reactor's callback
Returns application-specific data associated with a reactor
Overwrites application-specific data associated with a reactor
Constructs an editor reactor object that notifies of a deep clone event
Constructs a reactor object that notifies of events relating to drawing documents
Constructs an editor reactor object that notifies of a drawing event (for example, opening or closing a drawing file)
Constructs an editor reactor object that notifies of an event related to reading or writing a DXF file
Constructs an editor reactor object
Constructs an editor reactor object that notifies of an event related to block insertion
Constructs a reactor object that notifies your application every time an ObjectARX application is loaded or unloaded
Constructs an editor reactor object that notifies of a LISP event
Constructs an editor reactor object that does not fall under any other editor reactor types
Constructs an editor reactor object that notifies of a mouse event (for example, a double-click)
Determines whether or not a reactor will fire if its associated namespace is not active
Constructs a drawing object reactor object
Adds an object to the list of owners of an object reactor
Removes an object from the list of owners of an object reactor
Returns the list of owners of an object reactor
Returns a list of persistent reactors in the current drawing document
Determines whether a reactor is persistent
Makes a reactor persistent
Makes a reactor transient
Returns a list of all possible callback conditions for this reactor type
Adds or replaces a callback function in a reactor
Returns a list of pairs (event-name . callback_function) for the reactor
Returns a list of existing reactors
Disables all reactors of the specified type
Disables a reactor
Defines whether a reactor's callback function will execute if its associated namespace is not active
Constructs an editor reactor object that notifies of a change to a system variable
Constructs an editor reactor object that notifies of a change to the bitmaps in a toolbar
A predefined callback function that prints one or more callback arguments in the Trace window
Returns a symbol representing the reactor type
Returns a list of all reactor types
Constructs an editor reactor object that notifies of an undo event
Constructs an editor reactor object that notifies of an event related to writing a block
Constructs an editor reactor object that notifies of an event related to moving or sizing an AutoCAD window
Constructs an editor reactor object that notifies of an event related to attaching or modifying XREFs
Returns a list of viewport descriptors for the current viewport configuration